Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 11th April 2010, 20:24   #1
BHPian
 
Join Date: Nov 2008
Location: Bangalore
Posts: 105
Thanked: 2 Times
Default Car loses power and engine stops after 20KM in city - Fiat Palio 1.2 ELX 2001 model

Hey folks,

The car, as written above, is a Palio ELX run about 79k kms. I think a bit if history is probably pertinent here.

July 2009: The car was losing coolant at an alarming rate and one morning, after I’d topped up the tank with water, I forgot to put the cap back on. The whole thing ended up in me replacing the water tank.

Sep 2009: The radiator fan stopped working and I had only the motor replaced @ Green Tracks Bangalore.

March 29th, 2010: Car stops at Kundalahalli signal and the engine temperature has soared. The tow car came and the immediate diagnosis was that the battery had gone weak and was not providing enough power. The car was towed to KHT motors and Arun, the SA was responsible for the service/replacement of parts. Brake pads and shoes were changed, the master and clutch cylinders were replaced and the coolant ‘dummy’ tanks were also replaced. I’d informed Arun about the poor pickup and mileage and also the overheating issue. He assured me that all had been fixed along with a myriad other issues the car had been facing after 6k odd kms with no service and also that the battery had been recharged.

April 10, 2010: The car just stopped after driving 20 odd kms in heavy traffic. The battery had conked. Got the battery replaced and put in a brand new one.

April 11, 2010: Had to go to Yeshwantpur from Lingarajpuram (approx. Distance: 12Kms one way) and the car was fine until we had almost reached lingrajpuram on the way back when the car just lost all power and coasted to a stop. The battery was fine because I could crank the engine but the engine just wouldn’t catch and stay on. Trudged to my friend’s place and called the KHT helpline and the tow car came @ about 4(prompt. Full marks to the tow guys who told me they’d be there by 4). We started the car and the car started! I took a small round and everything seemed okay so sent the guys off and started for home on Bannerghatta road, about 23 kms away. Just about 2 kms away from home, the car lost all power, jerked and coasted to a stop. Had to wait for an hour and since home was close, I risked it and got the car back home. The temp showed just below the halfway mark.

Sorry about the long post but I felt I had to explain the whole chronology of events in detail.

I’ll be calling the KHT guys again tomorrow but any ideas what the problem could be? Is there anything in specific I could tell the guy to help him?

Any help is greatly appreciated.

Last edited by wannabe loser : 11th April 2010 at 20:25.
wannabe loser is offline   Reply With Quote
Old 11th April 2010, 20:40   #2
Awaiting Email Confirmation
 
Join Date: Jun 2005
Location: ERNAKULAM
Posts: 947
Thanked: 317 Times
Default Gradation in power loss

Please tell me whether you have power loss all of a sudden or is it gradual.

If its gradual make sure that the petrol caps orifice is not completely blocked. In a friends car negative pressure built up in the tank due to a blocked orifice was the culprit and changing the cap ameliorated the problem.
Another issue is to check up fuel pressures from the fuel pump.

If its sudden loss in power there could umpteen reasons.

Do let the group know how the loss in power feels.
drpullockaran is offline   Reply With Quote
Old 11th April 2010, 20:56   #3
BHPian
 
Join Date: Nov 2008
Location: Bangalore
Posts: 105
Thanked: 2 Times
Default

Quote:
Originally Posted by drpullockaran View Post
Please tell me whether you have power loss all of a sudden or is it gradual.

If its gradual make sure that the petrol caps orifice is not completely blocked. In a friends car negative pressure built up in the tank due to a blocked orifice was the culprit and changing the cap ameliorated the problem.
Another issue is to check up fuel pressures from the fuel pump.

If its sudden loss in power there could umpteen reasons.

Do let the group know how the loss in power feels.
It's quite sudden. if i had to draw a graph, it would go from 100% to 75% to 0%

Pressing the accelerator does absolutely nothing. The engine shudders for sometime and dies. If the car is moving, pressing the clutch seemed to make it go faster than in gear.

Thanks.
wannabe loser is offline   Reply With Quote
Old 11th April 2010, 21:59   #4
Awaiting Email Confirmation
 
Join Date: Jun 2005
Location: ERNAKULAM
Posts: 947
Thanked: 317 Times
Default Engine shudder

Since you specifically mentioned the word shudder I feel that your electrical's need a once over. First I would swap the High voltage Transistor ignition unit with a spare which takes about 10 minutes to change. I am guessing that this problem creeps up in your car only after the engine block heats up.
Do that and get back to the forum after that.
drpullockaran is offline   Reply With Quote
Old 11th April 2010, 22:48   #5
BHPian
 
Join Date: Nov 2008
Location: Bangalore
Posts: 105
Thanked: 2 Times
Default

Quote:
Originally Posted by drpullockaran View Post
Since you specifically mentioned the word shudder I feel that your electrical's need a once over. First I would swap the High voltage Transistor ignition unit with a spare which takes about 10 minutes to change. I am guessing that this problem creeps up in your car only after the engine block heats up.
Do that and get back to the forum after that.
Thanks! Will definitely try that! How much will the High voltage Transistor ignition unit cost approximately?

And any particular reason you think that could be the problem? Would love to learn.
wannabe loser is offline   Reply With Quote
Old 12th April 2010, 20:41   #6
BHPian
 
Join Date: Jun 2007
Location: Bangalore
Posts: 334
Thanked: 18 Times
Default

You feel sudden drop if this unit(Ignition coil and unit) is gone. Do also check the alternator. You can contact Mr. Venkatesh From Gowri Motors @9379192193 near sajjan Rao circle and he is a knowledgeable person on FIAT cars. can refer my name (Ravi GTX Sports). I had a gone engine head gasket two weeks back which troubled my life to the core. He has fixed that and it is running smooth now.
ravikn is offline   Reply With Quote
Old 12th April 2010, 22:37   #7
BHPian
 
Join Date: Nov 2008
Location: Bangalore
Posts: 105
Thanked: 2 Times
Default

Quote:
Originally Posted by ravikn View Post
You feel sudden drop if this unit(Ignition coil and unit) is gone. Do also check the alternator. You can contact Mr. Venkatesh From Gowri Motors @9379192193 near sajjan Rao circle and he is a knowledgeable person on FIAT cars. can refer my name (Ravi GTX Sports). I had a gone engine head gasket two weeks back which troubled my life to the core. He has fixed that and it is running smooth now.
Thanks Ravi! Will definitely talk to him as well. But since KHT serviced my car two weeks ago, I think they shud atleast take a look at the car.

OT: Are u selling your car by chance?
wannabe loser is offline   Reply With Quote
Old 13th April 2010, 00:22   #8
Awaiting Email Confirmation
 
Join Date: Jun 2005
Location: ERNAKULAM
Posts: 947
Thanked: 317 Times
Default Heat kills the ignition unit in the long run.

Quote:
Originally Posted by wannabe loser View Post
Thanks! Will definitely try that! How much will the High voltage Transistor ignition unit cost approximately?

And any particular reason you think that could be the problem? Would love to learn.
Inclusive of the wires it should not cost more than Rs 3000 including labor.

The ignition unit and alternator assembly are the ones that has given up the ghost in many Palios after the TATA's got a stake in FIAT India. With TATA's procurement policies and FIATS tight tolerances I was forced to buy a non FIAT product knowing fully well that there is nothing this side of 28 lakhs that can trounce my Palio GTX (I am not talking about acceleration alone) which I used to own till last September. Not even its newer siblings hold a candle to the GTX. If TATA had not tied up with FIAT I would have gone ahead and kept my GTX.

If it was a gradual loss in power it would be the fuel line but any sudden loss in power at elevated temperatures points to electrical units.
The ignition unit gives warning signals by coughing when the end is near by that I mean it sputters when the unit is hot before giving up the ghost. It will work when cold though for a few more months.

Last edited by drpullockaran : 13th April 2010 at 00:28.
drpullockaran is offline   Reply With Quote
Old 13th April 2010, 20:23   #9
BHPian
 
Join Date: Jun 2007
Location: Bangalore
Posts: 334
Thanked: 18 Times
Default

Quote:
Originally Posted by wannabe loser View Post
Thanks Ravi! Will definitely talk to him as well. But since KHT serviced my car two weeks ago, I think they shud atleast take a look at the car.

OT: Are u selling your car by chance?
Nope, I was thinking to sell but now that the investment on this car has crossed 1.2L after buying, am thinking to keep it for couple more years at least. Might sell if a good price is offered
ravikn is offline   Reply With Quote
Old 14th April 2010, 14:29   #10
BHPian
 
Join Date: Nov 2008
Location: Bangalore
Posts: 105
Thanked: 2 Times
Default

Quote:
Originally Posted by drpullockaran View Post
Inclusive of the wires it should not cost more than Rs 3000 including labor.

The ignition unit and alternator assembly are the ones that has given up the ghost in many Palios after the TATA's got a stake in FIAT India. With TATA's procurement policies and FIATS tight tolerances I was forced to buy a non FIAT product knowing fully well that there is nothing this side of 28 lakhs that can trounce my Palio GTX (I am not talking about acceleration alone) which I used to own till last September. Not even its newer siblings hold a candle to the GTX. If TATA had not tied up with FIAT I would have gone ahead and kept my GTX.

If it was a gradual loss in power it would be the fuel line but any sudden loss in power at elevated temperatures points to electrical units.
The ignition unit gives warning signals by coughing when the end is near by that I mean it sputters when the unit is hot before giving up the ghost. It will work when cold though for a few more months.
drpullockaran, that diagnosis is super! And, yes, just like you men tioned, the car moves when cold. I've called the KHT motors guys and they shgud have this fixed sometime tomorrow. Will keep you updated. And thanks for the knowledge! I really appreciate it.
wannabe loser is offline   Reply With Quote
Old 19th August 2010, 11:37   #11
BHPian
 
Join Date: Nov 2008
Location: Bangalore
Posts: 105
Thanked: 2 Times
Default Solution.

Sorry folks, It's been a long time and I'd gotten real busy so had forgotten to update.

As suggested, I took the car but nobody in Prerna Motors on Hosur road had heard about something called a High Voltage Transistor Ignition Unit. Spoke to Babu who I've known from Green Tracks and we went for a long drive. Gave the car and he told me that he'd look into the electricals and let me know the results. Turn out that the RPM sensor cable was conked and got it replaced. Cost Rs. 1000/-

Drove it around for a couple of days and the car didn't stop even after 30 kms of stop-and-go traffic. But the A/C was ineffective and the steering did get heavy after the engine reached the halfway mark. Even the engine did not pull cleanly after getting to the halfway mark. Car'd become almost unusable. Spoke to a mechanically inclined friend of mine who's been dabbling in the modding scene for sometime and he had a look. He didn't have the time to open up the engine but from what he could see, he said that the engine needed a once over. Took the car back to Prerna and got the engine serviced and topped up with Bardahl. Drove around for a couple of hundred kilometers real slowly below 3.5k rpm.

Been driving it around like that for sometime now and the problem seems to have sorted itself out completely.

Solution to my problem: Faulty RPM sensor cable. Also gave the engine a once over and it's as good as new.

Thanks for all your help buddies. Much appreciated.

I thought I'd update you on another development as well. Got a pay hike recently and decided to upgrade to a more powerful car. Searched for 1.6 Palios without luck. Finally ended up buying a OHC Vtec
wannabe loser is offline   Reply With Quote
Old 8th August 2011, 12:54   #12
BHPian
 
Join Date: May 2007
Location: Bangalore
Posts: 80
Thanked: 3 Times
Infractions: 0/2 (9)
Default Engine stops while on move

My palio 1.2 nv has a problem with the engine stopping while on move.
This happens when on 3rd/4th gear.It just stops.

I did all preleiminary checkings - scanned the cpu,cleaned the spark plugs, but this has come back again.

This is not very consistent though - normally happens when I am driving in city - 30/40 km.

My car has run only 26000 kms.

Any advice please - should I replace the sparkplugs?

Thanks
blrboy is offline   Reply With Quote
Old 8th August 2011, 13:16   #13
Senior - BHPian
 
ghodlur's Avatar
 
Join Date: Sep 2009
Location: Thane
Posts: 5,041
Thanked: 2,086 Times
Red face Re: Engine stops while on move

Quote:
Originally Posted by blrboy View Post
My palio 1.2 nv has a problem with the engine stopping while on move.
This happens when on 3rd/4th gear.It just stops.

I did all preleiminary checkings - scanned the cpu,cleaned the spark plugs, but this has come back again.

This is not very consistent though - normally happens when I am driving in city - 30/40 km.

My car has run only 26000 kms.

Any advice please - should I replace the sparkplugs?

Thanks
Apart from the Spark plugs, could be the case of Fuel line clogged due to bad fuel, Fuel filter clogged or may be the air filter must be clogged too. How long is it since the engine was serviced.

Maybe showing it to the service centre will throw up more solutions.
ghodlur is offline   (1) Thanks Reply With Quote
Old 8th August 2011, 13:43   #14
BHPian
 
Join Date: May 2007
Location: Bangalore
Posts: 80
Thanked: 3 Times
Infractions: 0/2 (9)
Default Re: Engine stops while on move

Quote:
Originally Posted by ghodlur View Post
How long is it since the engine was serviced.

Maybe showing it to the service centre will throw up more solutions.
I did show this to prerana motors, during service and also went specifically to check this problem alone.

I do service every 5-6 months, last is serviced was on May 2011.
blrboy is offline   Reply With Quote
Old 8th August 2011, 13:46   #15
BHPian
 
MalluDude's Avatar
 
Join Date: Aug 2005
Location: Cochin
Posts: 382
Thanked: 28 Times
Default Re: Engine stops while on move

Did they clean the injectors? Could be clogged due to bad fuel.
MalluDude is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
BMW India stops sale of M Peformance Power Kits *EDIT* Power kits are back! Akshay1234 The Indian Car Scene 52 11th September 2017 00:57
Mahindra TUV300 AMT loses engine power @ 100 kmph, AMT doesn't downshift silverknight Technical Stuff 21 25th November 2015 10:33
Yamaha RX100 - Engine loses steam, power cutoff @ 90 kph yamaniac Motorbikes 11 13th July 2015 11:27
Fiat Palio 1.6 vis-a-vis 1.2 (ELX): power matters trravindran Hatchbacks 0 15th October 2009 22:09
Fiat Petra 1.6 ELXP or Palio 1.6 sports or Palio 1.2 nv ELX? Travel-X Hatchbacks 20 8th November 2006 18:36


All times are GMT +5.5. The time now is 18:25.

Copyright ©2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks