Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 11th April 2010, 21:38   #1
Senior - BHPian
 
xingamazon's Avatar
 
Join Date: Sep 2009
Location: Chennai
Posts: 1,399
Thanked: 110 Times
Infractions: 0/1 (5)
Default Defogger indicator glowing in the instrument cluster for no reason.

Today while going on drive I noticed that there was a light glowing in the instrument cluster of my car (Zen Estilo). On reading the manual it was mentioned that particilar indicator glows when the defogger/ demisters is switched on.
I am pretty sure it was not switched on, I even switched it on and off again, just to be doubly sure, but still no luck.
I still have no clue what to do.
Hope it is not a big issue, or is it? My service is due two months hence, should I go to the service center and have it checked. Please help
xingamazon is offline   Reply With Quote
Old 11th April 2010, 21:41   #2
Senior - BHPian
 
sachinj12's Avatar
 
Join Date: Nov 2009
Location: Los Angeles
Posts: 1,188
Thanked: 161 Times
Default

Nothing to worry, probably a malfunction of the light. If everything else is fine, wait for the service.
sachinj12 is online now   Reply With Quote
Old 12th April 2010, 14:06   #3
Senior - BHPian
 
xingamazon's Avatar
 
Join Date: Sep 2009
Location: Chennai
Posts: 1,399
Thanked: 110 Times
Infractions: 0/1 (5)
Default

Quote:
Originally Posted by sachinj12 View Post
Nothing to worry, probably a malfunction of the light. If everything else is fine, wait for the service.
Hi Sachin, thanks for the points.
One additional thing I wanted to ask is is there someway that I can check if the thing has got switched on by some snag etc.
Will the defogger film be warm if I touch that, How can I make sure that its not working at all.
xingamazon is offline   Reply With Quote
Old 13th April 2010, 18:43   #4
Senior - BHPian
 
sachinj12's Avatar
 
Join Date: Nov 2009
Location: Los Angeles
Posts: 1,188
Thanked: 161 Times
Default

Quote:
Originally Posted by xingamazon View Post
Hi Sachin, thanks for the points.
One additional thing I wanted to ask is is there someway that I can check if the thing has got switched on by some snag etc.
Will the defogger film be warm if I touch that, How can I make sure that its not working at all.


I guess not. No, there is no harm in touching the rear window with the defogger on. Though warm, it is nothing dangerous of sort. Get it right here, its WARM, not HOT. Once you start the car, let the car idle for 5 min and see if your rear windows have heated up, you will get to know whether the defogger is switched on or not.
sachinj12 is online now   Reply With Quote
Old 14th April 2010, 11:42   #5
Team-BHP Support
 
Rehaan's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 22,381
Thanked: 22,606 Times
Default

Thats a strange issue.

I'm not to familiar with the Zen Estilo, but :
1) Why does the defogger have a light on the instrument cluster? Usually its on the switch.
2) Are you sure its the defogger light and not fog-light or something else?

If it is indeed the defogger, you can look around the periphery of your rear glass for a removable wire connector. If you find one, unplug it to be on the safe side.

cya
R
Rehaan is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Used Parts (Instrument cluster- dials) ..? gary_yuen42 Modifications & Accessories 38 9th April 2014 13:31
Handbrake indicator permanently glowing. Would my brakes fail? SDP Technical Stuff 35 20th February 2011 10:39
can the colour of the in dash instrument cluster lights be changed??? mclaren1885 Modifications & Accessories 23 22nd August 2009 16:04
Instrument cluster light change nikibusa Motorbikes 7 10th September 2005 09:26


All times are GMT +5.5. The time now is 21:20.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks