Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 8th August 2010, 14:43   #16
BHPian
 
Mr_Bean's Avatar
 
Join Date: Nov 2008
Location: Bangalore
Posts: 842
Thanked: 128 Times
Default Small update - issue not solved

The following components were checked at MASS:
Gear box - bushes were worn out, so replaced it & that explains the non-smooth shifts.

IACV checked
Tech scan done, no errors
Throttle body cleaned, recalibrated
Injection clean? - not sure if this was done, need to check
ignition coil working fine
spark plugs working fine.
Air filter cleaned, fuel filter cleaned.
Complete tuning done, vehicle feels smoother untill the problem sets in

1.) After all of the above, problem still exist & this just begins after driving the car for more than 6-8 km in peak traffic.
2.) The problem begins with increase in engine vibration at idle, vehicle is pretty slow to move in first gear, vibration sets in while releasing the clutch & jerk sets in 2nd and 3rd gear when i maintain the rpm between 2000-2500.. It is more pronounced when the AC is set on & a feeling that something is holding the vehicle from moving ahead.

Can ignition coil fail to deliver when it gets heated up?
Is fuel tank cleaning suggested? I stand at 48k kms..
Is visual inspection enough to figure out that injection cleaning is required or not?

I know I am a bit paranoid here but I am keen on getting this solved at the earliest.
Mr_Bean is offline   Reply With Quote
Old 9th August 2010, 17:24   #17
BHPian
 
Mr_Bean's Avatar
 
Join Date: Nov 2008
Location: Bangalore
Posts: 842
Thanked: 128 Times
Default

Bumping the thread, folks require your inputs
Mr_Bean is offline   Reply With Quote
Old 9th August 2010, 19:25   #18
BHPian
 
johnruben's Avatar
 
Join Date: Sep 2007
Location: Bangalore
Posts: 213
Thanked: 73 Times
Default

I am not a tech guy, but i feel either Engine Decarbonizing was not properly done (or) you might need to do clutch overhaul.... not sure, i guess the pro's here might answer, Wish you all the best for your baleno
johnruben is offline   Reply With Quote
Old 9th August 2010, 19:46   #19
Senior - BHPian
 
headers's Avatar
 
Join Date: May 2006
Location: Greater Chennai
Posts: 4,589
Thanked: 454 Times
Default

Quote:
Originally Posted by Mr_Bean View Post
I have been facing this issue for some time now, I want to get it resolved as fast as possible.

1.) The car jerks while slowing down during 1st, 2nd & 3rd gears (rpm well above 1500). It is quite easy to reproduce this:
Slight Jerk - Rev the car & keep it between 2000-2300rpm.

2.) Car is hesitant to revv with AC on in 2nd & 3rd gears. Feel like something is holding my car.

3.) There is a jerk, no matter how the slow the clutch is engaged after changing gears & even with a slight tap on the accelerator.

4.) Gear become tight & hard to operate after a period of high revving. clutch becomes hard & shuddering sets in.
Pt. 4 : Clutch release bearing worn out..

Quote:
Originally Posted by Mr_Bean View Post
New clutch assembly (everything)
Check whether the release bearing is changed!!!


Quote:
Originally Posted by nitrous View Post
Sounds like the ignition coil.
..
All said, Beans, you're a fussy lad.
Go for a Flame Thrower!!

Quote:
Originally Posted by Mr_Bean View Post
The following components were checked at MASS:
Gear box - bushes were worn out, so replaced it & that explains the non-smooth shifts.

IACV checked
Tech scan done, no errors
Throttle body cleaned, recalibrated
Injection clean? - not sure if this was done, need to check
ignition coil working fine
spark plugs working fine.
Air filter cleaned, fuel filter cleaned.
Complete tuning done, vehicle feels smoother untill the problem sets in

1.) After all of the above, problem still exist & this just begins after driving the car for more than 6-8 km in peak traffic.
2.) The problem begins with increase in engine vibration at idle, vehicle is pretty slow to move in first gear, vibration sets in while releasing the clutch & jerk sets in 2nd and 3rd gear when i maintain the rpm between 2000-2500.. It is more pronounced when the AC is set on & a feeling that something is holding the vehicle from moving ahead.

Can ignition coil fail to deliver when it gets heated up?
Is fuel tank cleaning suggested? I stand at 48k kms..
Is visual inspection enough to figure out that injection cleaning is required or not?

I know I am a bit paranoid here but I am keen on getting this solved at the earliest.
Could be that your Fuel pump solenoid is acting up!!

Quote:
Originally Posted by Mr_Bean View Post
Bumping the thread, folks require your inputs
Change your ENGINE bed Mounts..if all else seem OK,,bad mounts tend to give more engine vibrations at 1000-2000 rpm..

Last edited by headers : 9th August 2010 at 19:50.
headers is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Long pending introduction rohan_iitr Introduce yourself 9 19th August 2009 15:00
Long Pending Introduction from a New Member. VinodGK Introduce yourself 3 15th August 2009 14:05
What is the procedure for making a Taxi quoto vehicle to a Private vehicle? Pani The Indian Car Scene 1 12th January 2009 13:04
A Long Pending Intro sanju.sreekumar Introduce yourself 4 11th January 2009 00:10
Long Pending Intro Dicky_GT Introduce yourself 9 26th August 2008 17:25


All times are GMT +5.5. The time now is 22:09.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks