Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 28th July 2010, 16:20   #1
BHPian
 
monster2's Avatar
 
Join Date: Jan 2007
Location: Hyderabad
Posts: 77
Thanked: 5 Times
Default Esteem Wipers do not cut off automaticatlly

HI friends,

My Wiper motor was not working couple of days back, hence i took to the electrician, who just Cleaned the Carbon brushes, it works good now, but the issue is it does not cut off even after turning off the switch, however the car is turned off it gets turned off(Assuming Relay issue). My Esteem is 99 VX. Please throw in some light if there is any relay for Wipers specifically ill get it changed.
monster2 is offline   Reply With Quote
Old 28th July 2010, 17:12   #2
BHPian
 
Aarman_008's Avatar
 
Join Date: Aug 2009
Location: Chennai
Posts: 140
Thanked: 3 Times
Default

Quote:
Originally Posted by monster2 View Post
HI friends,

My Wiper motor was not working couple of days back, hence i took to the electrician, who just Cleaned the Carbon brushes, it works good now, but the issue is it does not cut off even after turning off the switch, however the car is turned off it gets turned off(Assuming Relay issue). My Esteem is 99 VX. Please throw in some light if there is any relay for Wipers specifically ill get it changed.
If it does not turn off even after turning off the switch, I believe the issue could be with the Wiper switch.
Aarman_008 is offline   Reply With Quote
Old 28th July 2010, 17:19   #3
BHPian
 
monster2's Avatar
 
Join Date: Jan 2007
Location: Hyderabad
Posts: 77
Thanked: 5 Times
Default Hi

Quote:
Originally Posted by Aarman_008 View Post
If it does not turn off even after turning off the switch, I believe the issue could be with the Wiper switch.
Hi Aarman,

I doubt the same as it runs in all speeds and even slows accordingly, just doesnt stop, sunds fishy link a cut off relay catch, I just want to identify where it is in order to replace it.
monster2 is offline   Reply With Quote
Old 28th July 2010, 18:05   #4
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,752
Thanked: 7,475 Times
Default

Check the switch first or the connectors and wiring from the switch to the motor.
Jaggu is offline   Reply With Quote
Old 28th July 2010, 23:17   #5
BHPian
 
kannan666's Avatar
 
Join Date: Aug 2007
Location: KA-02
Posts: 939
Thanked: 69 Times
Default

I suspect the switch wiring to be faulty too, were you able to identify and sort out the problem ?
kannan666 is offline   Reply With Quote
Old 29th July 2010, 00:53   #6
Senior - BHPian
 
Join Date: Sep 2006
Location: zxc
Posts: 3,394
Thanked: 658 Times
Default

Its a 99 esteem. Just check the the combination switch. If possibly change it. Its about Rs.680

Last edited by SirAlec : 29th July 2010 at 00:57.
SirAlec is offline   Reply With Quote
Old 29th July 2010, 13:52   #7
BHPian
 
ilangop's Avatar
 
Join Date: Jul 2008
Location: Pune/Neyveli
Posts: 913
Thanked: 578 Times
Default

Hi Monster,
Just need a clarification. Did your wiper turn off properly, just before it conked off? Inside the wiper motor, there is a limit switch that signals the wiper controller that the motor has reached the home position. By any chance if the singal is not reaching the controller, the motor will be held ON till the controller sees the signal. I dont see a fault with the combi switch, as you say all the speeds are working fine. I guess the INT function is not working now, but turns ON the wiper motors in slow speed. Am I right? If this is the case, then check the signal wire & the controller.
-Ilango
ilangop is offline   Reply With Quote
Old 29th July 2010, 16:34   #8
BHPian
 
monster2's Avatar
 
Join Date: Jan 2007
Location: Hyderabad
Posts: 77
Thanked: 5 Times
Default

HI Team,

I could not get the time to check with the problem because of my sad work timing, Ill get it checked with the electrician on Sat, However i checked with combination switch cost it is 1650, But then as ilogop said the switch works fine some issue with the wiring i feel, however the parts guy said to check Wiper link, can any one help with the pic to check where it is located.
monster2 is offline   Reply With Quote
Old 30th July 2010, 00:10   #9
Senior - BHPian
 
Join Date: Sep 2006
Location: zxc
Posts: 3,394
Thanked: 658 Times
Default

That is expensive. Esteem uses two part or single assembly?
SirAlec is offline   Reply With Quote
Old 30th July 2010, 01:00   #10
BHPian
 
ghpk's Avatar
 
Join Date: Mar 2009
Location: Ghaziabad
Posts: 869
Thanked: 192 Times
Default

Quote:
Originally Posted by monster2 View Post
HI Team,

I could not get the time to check with the problem because of my sad work timing, Ill get it checked with the electrician on Sat, However i checked with combination switch cost it is 1650, But then as ilogop said the switch works fine some issue with the wiring i feel, however the parts guy said to check Wiper link, can any one help with the pic to check where it is located.
It should be the wiper switch as the prime cause, May be the ON/OFF points are short making it run all the time,
Ask any mech to disconnect the outgoing power (from switch to wiper) then check using a small bulb, if the power still comes to output pin on combi-switch.
Rs.1650/- is quite expensive, Have you checked it on other spare part vendors, you certainly need to cross check the pricing at few shops as this price for a maruti based car looks more of a Rip off.
ghpk is offline   Reply With Quote
Old 30th July 2010, 15:55   #11
BHPian
 
monster2's Avatar
 
Join Date: Jan 2007
Location: Hyderabad
Posts: 77
Thanked: 5 Times
Default

Hi Team,

Ill take the car tomorrow to that electrician, I don't know how, but when i checked today morning it was working fine, but as i told you its intermittent, let me check with him and update you guys.

Thanks
Monster
monster2 is offline   Reply With Quote
Old 30th July 2010, 15:59   #12
BHPian
 
monster2's Avatar
 
Join Date: Jan 2007
Location: Hyderabad
Posts: 77
Thanked: 5 Times
Default

Quote:
Originally Posted by ghpk View Post
It should be the wiper switch as the prime cause, May be the ON/OFF points are short making it run all the time,
Ask any mech to disconnect the outgoing power (from switch to wiper) then check using a small bulb, if the power still comes to output pin on combi-switch.
Rs.1650/- is quite expensive, Have you checked it on other spare part vendors, you certainly need to cross check the pricing at few shops as this price for a maruti based car looks more of a Rip off.
I know what you said is true, but this is the only place in hyd who sells 100% mgp spare, infact you can find the MAruti spare that you never find outside, I checked with other stores also but just last week i go cheated when i bought a mirror inner cover from outside, so i thought its good to buy from the place where you get MGP assured parts. I know that 1650 is big, hence ill just confirm if thats the issue tommorow.
monster2 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Punto music system (not stock) not switching off after switching off engine!! praz Technical Stuff 17 9th March 2011 09:55
Palio 1.1 SLX: Fuel cut-off indicator prashkul Technical Stuff 13 14th May 2010 12:55
Fuel cut-off at max RPM in my Altis! Ym-enjn Technical Stuff 49 28th November 2008 16:48
Turn Indicator light does not cut off automatically Shashank.A Technical Stuff 19 16th November 2008 08:47
And one TBHPian cut off another! Steeroid Street Experiences 15 27th December 2005 18:50


All times are GMT +5.5. The time now is 00:37.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks