Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 29th August 2010, 16:53   #1
BHPian
 
mathew1105's Avatar
 
Join Date: Aug 2008
Location: Chennai
Posts: 53
Thanked: 9 Times
Default Figo Bluetooth Issues

I have a Nokia E71. The sales rep paired my phone with the car when I took delivery three months ago. Since then it would work for a few days and sometimes not. It would sometimes connect, but not let me access the phonebook or Dial or Missed calls list. I would reset the phone and the system then connect, disconnect & reconnect and it starts working again.
I thought I would have it fixed, when it goes for the 1st service.

When I took the car the other day to the service center, The service people could not fix it. Then the Service manager called the supplier of the system in chennai to talk to him to see what can be done. And the guy after finding out my mobile model number, he tells him "It does not work on the E71" it the sales guys who sell the car saying it works on all phones. Actually it does not work on all mobile models, it works only on selected models. I'm like, Really!! I told the manager, If it's a compatability issue and if it's designed that way, It should never connect to my phone. Not like, work on some days and sometimes not. and it looks more like a 'Firmware' issue.

He then spoke to spoke to Ford and explained the situation after which he told me that he'll get back to me.Still waiting for a reply from him.
My Question to other Figo owners.
1. Are you having issues connecting your Nokia phones.
2. Does it work consistently.
3. My Redial list & SMS notification has not worked since day one, Any one else has the same issue.
Thank you all for your help & support in advance.
mathew1105 is offline   Reply With Quote
Old 29th August 2010, 19:38   #2
BHPian
 
aditya.86's Avatar
 
Join Date: Oct 2006
Location: Beaumont, TX
Posts: 222
Thanked: 10 Times
Default

Hey there!

The bluetooth enabled system on the Figo is one of the best features of the car. Regarding compatibility issues i think its something wrong with your phone.

A friend of mine picked up a Figo titanium a month back and the set is working absolutely fine. In fact we have paired almost 4-5 phones with the headunit which includes W890i, E63, E72, Samsung corby etc. All these phones had no issues at all. Since yours is an E71 i dont think there should be any compatiblility issues with the system in the car. There are chances that the system in the car is also the culprit.

ADi
aditya.86 is offline   Reply With Quote
Old 29th August 2010, 19:51   #3
Senior - BHPian
 
Join Date: Sep 2008
Location: Bangalore
Posts: 1,891
Thanked: 19 Times
Default

Check with the user manuel of E71 as well as FIGO BT system
check specifically for which all profiles are avaiable. Ensure that the profile on both the side is same
StarVegabond is offline   Reply With Quote
Old 29th August 2010, 20:24   #4
Senior - BHPian
 
anilisanil's Avatar
 
Join Date: Jun 2010
Location: Pune
Posts: 1,435
Thanked: 288 Times
Default

I have a Nokia 5800 and bluetooth connectivity works like charm!! In fact as Aditya said it is among the best features of the car!!

To help you, After pairing the car I have set the car's system as authorized. It gets connected in the car mode!
anilisanil is offline   Reply With Quote
Old 30th August 2010, 09:04   #5
BHPian
 
mathew1105's Avatar
 
Join Date: Aug 2008
Location: Chennai
Posts: 53
Thanked: 9 Times
Default

Quote:
Originally Posted by anilisanil View Post
I have a Nokia 5800 and bluetooth connectivity works like charm!! In fact as Aditya said it is among the best features of the car!!

To help you, After pairing the car I have set the car's system as authorized. It gets connected in the car mode!
I agree with you guys on that. That's how I have it. It dosn't have any problem detecting the phone or connecting to it. However after it connects,Lets say I try to access the phone book, It'll show the name as on the phone's directory, but won't show the number it'll say "No Entry". Sometimes the phone book alone will work, the other features won't work.

Quote:
Originally Posted by aditya.86 View Post
A friend of mine picked up a Figo titanium a month back and the set is working absolutely fine. In fact we have paired almost 4-5 phones with the headunit which includes W890i, E63, E72, Samsung corby etc. All these phones had no issues at all. Since yours is an E71 i dont think there should be any compatiblility issues with the system in the car. There are chances that the system in the car is also the culprit.ADi
True, What I was surprised was, When the Service Manager called the supplier to see what can be done he says "It does not work on all the phones" and it won't work on "E71". The sales people are misguiding the people saying "it works on all phones".

I know that's not the case, That's why I wanted to get more info on it, So I can talk to them when they get back to me.

I doub't if that could be a problem with the phone,Because since Day one I haven't been able to access Redial or get any SMS notifications. Even on the days when everything else works.
mathew1105 is offline   Reply With Quote
Old 30th August 2010, 10:31   #6
Senior - BHPian
 
anilisanil's Avatar
 
Join Date: Jun 2010
Location: Pune
Posts: 1,435
Thanked: 288 Times
Default

Mathew, did you try connecting other phones? Is it the problem with all the phones? Also check out if it is problem with your phone too!

And by the way, SMS and email notification do not work on Figo, AFAIK. Its just audio streaming and call management and nothing else!
anilisanil is offline   Reply With Quote
Old 30th August 2010, 10:40   #7
BHPian
 
Join Date: Jul 2010
Location: Bangalore
Posts: 60
Thanked: Once
Default

SMS notification works well with my Samsung Corby. However I have noticed that sometime call comes on phone instead on Head Unit although its paired. But its very rare. Happened only 2-3 times during my 3 months ownership.
perseus is offline   Reply With Quote
Old 30th August 2010, 10:56   #8
Senior - BHPian
 
anilisanil's Avatar
 
Join Date: Jun 2010
Location: Pune
Posts: 1,435
Thanked: 288 Times
Default

Quote:
Originally Posted by perseus View Post
SMS notification works well with my Samsung Corby. However I have noticed that sometime call comes on phone instead on Head Unit although its paired. But its very rare. Happened only 2-3 times during my 3 months ownership.
^^ Thanks Perseus, I stand corrected then. Unfortunately, SMS notification does not work on with Nokia 5800!
anilisanil is offline   Reply With Quote
Old 30th August 2010, 11:32   #9
BHPian
 
mathew1105's Avatar
 
Join Date: Aug 2008
Location: Chennai
Posts: 53
Thanked: 9 Times
Default

Quote:
Originally Posted by anilisanil View Post
Mathew, did you try connecting other phones? Is it the problem with all the phones? Also check out if it is problem with your phone too!

And by the way, SMS and email notification do not work on Figo, AFAIK. Its just audio streaming and call management and nothing else!
Thanks Anil, I just tested with my wife's Blackberry. I'm having the same Issues. I was able to dial the phone number through the phone and it works through the car Audio. However when I tried to access the phone book or Redial or Dialed or Missed Calls nothing worked.

I then connected my phone again, It let's me access the phone book & Dialled numbers but not the missed or received calls. It says "No Entry".

The SMS notification thing, I think it says on the booklet.
mathew1105 is offline   Reply With Quote
Old 3rd September 2010, 22:17   #10
BHPian
 
mathew1105's Avatar
 
Join Date: Aug 2008
Location: Chennai
Posts: 53
Thanked: 9 Times
Default

Continuation of the Story, After so many phone calls and follow up and an email to the President's desk. Finally I receive a call today from the service manager and he tells me this,
The order for the Audio system has been placed, It'll be available on Monday, However we would like to check you phone with another system before Installing the new one. And also the supplier has sent the list of phone that'll work with the system.
I told him about what other Figo owners had to say about the connectivity on T-BHP. and also that I'm having the same issues when I connect a Blackberry. He then says, Ok sir, not a problem the order is placed, I just want to make sure, it's not an issue with the phone. He said he'll take the car next week to fix it. I'm not sure what they are going to come up with next week!!
mathew1105 is offline   Reply With Quote
Old 9th September 2010, 00:39   #11
BHPian
 
mathew1105's Avatar
 
Join Date: Aug 2008
Location: Chennai
Posts: 53
Thanked: 9 Times
Default

Hey Guys Here's the update,
The Service Manager called me yesterday to tell me Ford is talking to it's supplier and will get back to me in a couple of more days??? I was like 'OK'.
Later, He calls me again today and tells me, The supplier 'Visteon' has responded back to the querey and they are saying E71 is not compatible?? I was like WHATEVER!!, Just fix the other flaws in the car!! They have taken the car in the evening, Hopefully I'll get it tomorrow.
I have still not given up on the Audio System yet,However I wanted the other things fixed first. Once it's back, I'm going to test it on all of my friend's phone and I'm also planning to ask the service manager for the 'So called List of Phones' the Figo's Audio system is compatible with!
Will keep you guys updated!
mathew1105 is offline   Reply With Quote
Old 9th September 2010, 11:10   #12
Senior - BHPian
 
anilisanil's Avatar
 
Join Date: Jun 2010
Location: Pune
Posts: 1,435
Thanked: 288 Times
Default

So are they replacing the audio system or not? Bluetooth streaming is one of USP of the Figo and don't buy their crap unless you are really satisfied! I remember you writing somewhere that it was not working with you wife's BB as well and also that you solved the problem yourself by resetting and re-pairing the phones and car's bluetooth!
anilisanil is offline   Reply With Quote
Old 9th September 2010, 22:51   #13
BHPian
 
mathew1105's Avatar
 
Join Date: Aug 2008
Location: Chennai
Posts: 53
Thanked: 9 Times
Default

Hey Anil, Spoke to the Regional Service Manager - Ford Today (I'm going to update the entire story on the other thread)

http://www.team-bhp.com/forum/techni...ack-marks.html (My Figo's boot has some crack marks!!)

He told me that E71 is not compatible and also said that he'll give the list of phones that the audio system is compatible with. When I asked about my wife's phone, he wanted me to message him the model number and he'll get back to me by tomorrow.
Although he gave an explanation for it, I'm going to wait till I get the car back and also the list from him and going to test the phones on the list on the audio system.
For now they've said they cannot do anything about it.
mathew1105 is offline   Reply With Quote
Old 17th September 2010, 19:06   #14
BHPian
 
sumathindra's Avatar
 
Join Date: Apr 2010
Location: Bangalore
Posts: 605
Thanked: 191 Times
Default

Quote:
Originally Posted by mathew1105 View Post
and also that I'm having the same issues when I connect a Blackberry.
you mentioned blackberry and hence i was tempted to respond! i have paired a w595 and a blackberry bold 9000 and it works perfectly fine in my figo. I think you are right the issue could be with the system and not the phone!
sumathindra is online now   Reply With Quote
Old 22nd December 2010, 05:24   #15
Newbie
 
Join Date: Apr 2006
Location: Chennai
Posts: 9
Thanked: 0 Times
Default Inconsistent Playback

When I purchased my Figo last month, the first thing I check was the Bluetooth connectivity, My Nokia E63 got successfully paired. Everything was fine.

Today I had a strange problem, my friend connected his Samsung Corby and played a song frm his fone. within 10 seconds the song stopped. The phone found it difficult to disconnect frm "Ford My Connection". Then I turned off the BT on the Head Unit and then switched off the car audio. Then I paired my E63 again, here started the problem, I played a song frm my phones Music Player. Every now n then in the middle of the song the Audio was goin down n up (like some weak signal). Later in the evening I tried playing songs frm my phone while driving. Again the same problem. The Audio Playback was not consistent.

Its understood if the phone is few meters away outside the car, but seems strange when the phone is right above the Head Unit on the dashboard...

Anyone else with similar problem and hav found solution, Plz Help me.
avinaush is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth pairing issues with Audio Head-Unit triedeverything In-Car Entertainment 12 16th June 2012 10:07
Ford Figo Booking and Delivery Issues joe1980 The Indian Car Scene 760 13th July 2011 11:08
Bluetooth car kit or Bluetooth HU? thefreak In-Car Entertainment 53 24th November 2009 12:59


All times are GMT +5.5. The time now is 13:10.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks