Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 8th May 2013, 13:27   #31
Senior - BHPian
vikram_d's Avatar
Join Date: Jul 2006
Location: Bangalore
Posts: 2,374
Thanked: 914 Times
Default Re: Automatic Climate Control issue in Suzuki SX4

Originally Posted by beast_within View Post
Now my query goes like this-

Since the temperature is not set to the lowest position ("Lo"), is ACC still mixing some amount of hot air and compensating this with full blower speed for a longer duration to bring down temperature inside the cabin?

Or the ACC logic is intelligent enough not to mix the hot air with cold air (although the temperature is not set to the lowest possible value). Since mixing of hot air is not required in this case and will only decrease cooling performance.

In other words I wish to know if the ratio of Cold:Hot air is hard coded into the ACC logic for very temperature value (Lo, 18, 19......31, 32, Hi) and only the fan speed is varied based on the inputs from various sensors.
The ACC uses a simple logic. It runs at full blast till the set temperature is reached and after that it starts mixing hot air, lowers the fan speed etc. to maintain the set temperature.

This is a very simple explanation, but I am sure it also takes feedback from the various sensors to figure out the rate at which cooling is happening.
vikram_d is offline   (1) Thanks Reply With Quote
Old 8th May 2013, 14:12   #32
Kaumad's Avatar
Join Date: Jul 2010
Location: Chennai
Posts: 126
Thanked: 112 Times
Default Re: Automatic Climate Control issue in Suzuki SX4

On the lines of what Vikram had mentioned earlier, please also get the ECT sensor checked. A faulty ECT sensor sends erratic temperature readings to the ECU which tends to cut the a/c compressor off sporadically.
Happened to me on my SX4.
Kaumad is offline   Reply With Quote
Old 10th May 2013, 12:25   #33
S5157's Avatar
Join Date: Sep 2009
Location: Muvattupuzha, KL
Posts: 276
Thanked: 129 Times
Default Re: Automatic Climate Control issue in Suzuki SX4

I have received the car back and issue seems to be resolved. I couldn't at the workshop during the fix but as per MASS, they have removed and cleaned thermistor and cooling coil. I have driven the car for ~50 KMS and compressor is working well.

Thanks for all the help.
S5157 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Queries about automatic and manual climate control vasu Technical Stuff 19 8th November 2015 13:47
Swift automatic climate control - blinking 'auto' sjohn Technical Stuff 11 14th November 2010 21:39
Optra Magnum with Automatic Climate Control students The Indian Car Scene 26 5th June 2008 15:34
Optra Magnum has added a feature - Automatic Climate Control manojgautham The Indian Car Scene 2 27th May 2008 03:14

All times are GMT +5.5. The time now is 13:47.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks