Go Back   Team-BHP > BHP India > Team-BHP Reviews > Test-Drives & Initial Ownership Reports


Reply
 
Thread Tools Search this Thread
Old 23rd November 2009, 11:22   #16
Senior - BHPian
 
Ramsagar's Avatar
 
Join Date: Dec 2006
Location: Bangalore-Nellore
Posts: 1,328
Thanked: 40 Times
Default

Congrats. Raining Fiesta-S. What was the on-road price and accessories etc?

You were ruined by fiesta driving pleasure, made you looted the bank after 6 months.
Can guess the no of sleepless night you had to own this beauty.
Ramsagar is offline   Reply With Quote
Old 25th July 2010, 01:19   #17
Awaiting Email Confirmation
 
Join Date: Oct 2009
Location: Hyderabad
Posts: 51
Thanked: 33 Times
Default

Hello Guys,
Anyone is facing any issue with the ABS or noticed something abnormal with it? Lately I did some very hard breaking with my S mostly from above 150 Kmph and noticed extremely poor response from the brakes, the break pedal went dead (Pressed to the last limit) with car just refusing to stop, it was rolling uncontrollably. Everything works fine for speed at and below 120kmph. I am not sure if this is because of the speed or there is something wrong with the carís ABS.
Can someone please try same if possible with brake pedal fully pressed at speed above 150 and see if you get same response.
DipantS is offline   Reply With Quote
Old 26th July 2010, 08:00   #18
Senior - BHPian
 
ghodlur's Avatar
 
Join Date: Sep 2009
Location: Thane
Posts: 5,041
Thanked: 2,086 Times
Red face

Quote:
Originally Posted by DipantS View Post
Hello Guys,
Anyone is facing any issue with the ABS or noticed something abnormal with it? Lately I did some very hard breaking with my S mostly from above 150 Kmph and noticed extremely poor response from the brakes, the break pedal went dead (Pressed to the last limit) with car just refusing to stop, it was rolling uncontrollably. Everything works fine for speed at and below 120kmph. I am not sure if this is because of the speed or there is something wrong with the carís ABS.
Can someone please try same if possible with brake pedal fully pressed at speed above 150 and see if you get same response.
There is definitely something wrong with the ABS unit. Pls get it checked at the earliest with nearest Ford dealer. It has nothing to do with speed. At the speeds you are talking about the ABS should come into action instantly upon hard breaking. Even at 60 kmph I had to break hard and my Zxi came to a screeching halt almost immediately with the ABS coming into action. I could feel the ABS operation with my feet on the brakes.
ghodlur is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Go Fida ... My new Ford Fiesta 1.6S ..Aquarius Blue nityanand.s.s Test-Drives & Initial Ownership Reports 64 14th September 2014 12:42
My Blu-Monster- Ford Fiesta 1.6S Aquarius Gilead Test-Drives & Initial Ownership Reports 507 26th August 2012 23:23
City vs Fiesta1.6 vs Fiesta 1.4 vs Swift vdi - brain vs heart problem irdevanand Sedans 50 19th January 2010 12:51
Aveo1.4/Fiesta1.4/Swift Diesel kvigneshbhasker Hatchbacks 21 8th March 2007 22:33


All times are GMT +5.5. The time now is 04:14.

Copyright ©2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks