Go Back   Team-BHP > BHP India > Team-BHP Reviews > Test-Drives & Initial Ownership Reports


Reply
 
Thread Tools Search this Thread
Old 1st November 2011, 10:25   #5566
BHPian
 
Join Date: Nov 2009
Location: Bangalore
Posts: 832
Thanked: 201 Times
Default re: Review: 1st-gen Ford Figo (2010)

Quote:
Originally Posted by Mustang.101 View Post
Drive carefully, you never know what comes on the road all of a sudden. Examples include dog, cattle, broken expressway guard rails, once i broke my windshield after i hit an eagle which was flying low and perpendicular to the road.
Wow, Killing an Eagle is incredibly bad luck.
And no, I'm on stock goodyear GTIII. There is a speedo error I guess.
wildsdi5530 is offline   Reply With Quote
Old 1st November 2011, 11:05   #5567
Senior - BHPian
 
anilisanil's Avatar
 
Join Date: Jun 2010
Location: Pune
Posts: 1,435
Thanked: 287 Times
Default re: Review: 1st-gen Ford Figo (2010)

Quote:
Originally Posted by sansvk View Post
On my Diwali trip from Bangalore to Palakkad, I noticed that the AC effectiveness suddenly dropped after 400kms of driving. I thought it would have some to do with the AC system. Since my hometown was close by, I decided to switch off the AC drive with the windows rolled down. On the return journey with a fresh start, the AC worked fine again for another 400 odd kms and suddenly died. This time I noticed that the blower wasnt working as it should, changing speed from 1 to 2 or 3 didnt make any difference. Today morning it was all fine again. Does anyone know what could have caused this problem? Anyhow planning to take it for the 20K service later this week.
Man!! I was about to post the same!!

Same thing happened to me too! The blower just doesn't work after 400Kms. So I turn it off for sometime and it is back to normal again!! I wonder what is wrong? I too got the white misty thing out of the vents!!

But now the a/c is back to its normal working and there is no point in going to a.s.s as they dismiss the problem.

Quote:
Originally Posted by wildsdi5530 View Post
Wow, Killing an Eagle is incredibly bad luck.
I killed a wood pecker, but with the bumper!! Damn, it was gory and sorry!

Last edited by anilisanil : 1st November 2011 at 11:08.
anilisanil is offline   Reply With Quote
Old 1st November 2011, 11:10   #5568
BHPian
 
isldhn's Avatar
 
Join Date: Nov 2008
Location: Ludhiana
Posts: 195
Thanked: 8 Times
Default re: Review: 1st-gen Ford Figo (2010)

Hey everyone. Was looking to buy the Ford Figo. I was wondering whether there is any plan of launching the facelifted version as discussed some time ago. I really do not want to end up with the last of the old version Figo's on road.
@ Mustang: Do confirm sir whether any insider information is available on the same.
isldhn is offline   Reply With Quote
Old 1st November 2011, 11:13   #5569
BANNED
 
Join Date: Feb 2010
Location: New Delhi
Posts: 1,316
Thanked: 233 Times
Default

Quote:
Originally Posted by wildsdi5530
Wow, Killing an Eagle is incredibly bad luck.
And no, I'm on stock goodyear GTIII. There is a speedo error I guess.
Talking about goodyear gt3, i just discovered a 1 cm long cut on my front passenger side tyre. Its near the rim and has only affected the top layer of the tyre and no air is leaking out.

Can any of you guys suggest what has to be done? Get a replacement or get this fixed and use it as a spare?


Quote:
Originally Posted by anilisanil

Man!! I was about to post the same!!

Same thing happened to me too! The blower just doesn't work after 400Kms. So I turn it off for sometime and it is back to normal again!! I wonder what is wrong? I too got the white misty thing out of the vents!!

I killed a wood pecker, but with the bumper!! Damn, it was gory and sorry!
That white misty thing is ice. It is normal and sometimes does happen owing to weather conditions.

Regarding the ac fan speed thing, did it happen while it was raining?


@others - there is an event scheduled on the 7th but i have no idea regarding it. I have a hunch that it might be a cosmetic facelift for the figo or a new car will be revealed (remember how the figo was revealed in nov only for the first time).

Last edited by Mustang.101 : 1st November 2011 at 11:19.
Mustang.101 is offline   (1) Thanks Reply With Quote
Old 1st November 2011, 11:37   #5570
Distinguished - BHPian
 
dhanushs's Avatar
 
Join Date: Oct 2009
Location: Bathery/BLR
Posts: 3,314
Thanked: 3,661 Times
Default re: Review: 1st-gen Ford Figo (2010)

Quote:
Originally Posted by anilisanil View Post
The blower just doesn't work after 400Kms.
Quote:
Originally Posted by sansvk View Post
AC effectiveness suddenly dropped after 400kms of driving..
...time I noticed that the blower wasnt working as it should, changing speed from 1 to 2 or 3 didnt make any difference.
Guys, even I faced the exact same problem on a Figo Exi, after about ~400kms drive from Goa to Kerala. ie, the blower was working at a reduced speed/temperature

Finally, we diagnosed the problem to be somehow associated with the temperature/direction control. When you switch off the car and start after, say about 20mins, there is no such problem. And it starts only when you touch the temperature controls.

Ford A.S.S has no idea about the problem.
dhanushs is offline   (1) Thanks Reply With Quote
Old 1st November 2011, 11:42   #5571
BHPian
 
isldhn's Avatar
 
Join Date: Nov 2008
Location: Ludhiana
Posts: 195
Thanked: 8 Times
Default re: Review: 1st-gen Ford Figo (2010)

@others - there is an event scheduled on the 7th but i have no idea regarding it. I have a hunch that it might be a cosmetic facelift for the figo or a new car will be revealed (remember how the figo was revealed in nov only for the first time).[/quote]

Hey thanks mustang for the quick reply. Now that is good news,if true.
Has Ford launched/revamped the Figo in any part of the world as yet. I know it is being pushy, but could you please find out more about this event of 7th Nov. I was about to get the booking done,so I need to be very sure about it. I love the Figo for what it is,but I would'nt mind if the interiors are spruced up a bit ,which most likely would be the case.
isldhn is offline   Reply With Quote
Old 1st November 2011, 11:46   #5572
BANNED
 
Join Date: Feb 2010
Location: New Delhi
Posts: 1,316
Thanked: 233 Times
Default

Quote:
Originally Posted by isldhn
@others - there is an event scheduled on the 7th but i have no idea regarding it. I have a hunch that it might be a cosmetic facelift for the figo or a new car will be revealed (remember how the figo was revealed in nov only for the first time).
Hey thanks mustang for the quick reply. Now that is good news,if true.
Has Ford launched/revamped the Figo in any part of the world as yet. I know it is being pushy, but could you please find out more about this event of 7th Nov. I was about to get the booking done,so I need to be very sure about it. I love the Figo for what it is,but I would'nt mind if the interiors are spruced up a bit ,which most likely would be the case.[/quote]

Hi, i wont be able to get more details for you as most of us here do not know what it is about, the PR dept is also tight lipped on it. What i suggest you to do is get the booking done now and then state explicitly to he dealer that you might go for an updated figo if it launches on the 7th of this month.
Mustang.101 is offline   Reply With Quote
Old 1st November 2011, 12:06   #5573
BHPian
 
Join Date: Jun 2009
Location: Chennai
Posts: 284
Thanked: 56 Times
Default re: Review: 1st-gen Ford Figo (2010)

Quote:
Originally Posted by sansvk View Post
On my Diwali trip from Bangalore to Palakkad, I noticed that the AC effectiveness suddenly dropped after 400kms of driving. I thought it would have some to do with the AC system. Since my hometown was close by, I decided to switch off the AC drive with the windows rolled down. On the return journey with a fresh start, the AC worked fine again for another 400 odd kms and suddenly died. This time I noticed that the blower wasnt working as it should, changing speed from 1 to 2 or 3 didnt make any difference. Today morning it was all fine again. Does anyone know what could have caused this problem? Anyhow planning to take it for the 20K service later this week.

The problem is due to ice formation on the cooling fins. This blocks the air flow and you get a feeling of reduced blower speed. Once you switch off the AC, the ice melts and AC will work normally till ice forms again.

Check your AC at the earliest.
raju2512 is offline   Reply With Quote
Old 1st November 2011, 12:53   #5574
BHPian
 
akshay380's Avatar
 
Join Date: Sep 2011
Location: Goa/Bangalore
Posts: 626
Thanked: 360 Times
Default re: Review: 1st-gen Ford Figo (2010)

^^ From what I hear, its a Fiesta AT. I am getting delivery of my Figo on 7th so if it indeed is a facelift than am at loss. Hoping for the best.
akshay380 is online now   Reply With Quote
Old 1st November 2011, 13:38   #5575
RGK
Senior - BHPian
 
RGK's Avatar
 
Join Date: Feb 2010
Location: DPM and CHN
Posts: 1,342
Thanked: 187 Times
Default re: Review: 1st-gen Ford Figo (2010)

Quote:
Originally Posted by figo_mba View Post
No there could possibly be no such cutoff.
I drove once from chennai to karur and there was no cutoff noticed and this was in mid april. Temperature was on 40s something outside.
Quote:
Originally Posted by sansvk View Post
On the return journey with a fresh start, the AC worked fine again for another 400 odd kms and suddenly died. Today morning it was all fine again. Does anyone know what could have caused this problem?
Quote:
Originally Posted by english View Post
sansvk, I guess its an auto cut off safety feature. Did you drive 400km without any halts or you had any stoppages in between?
Quote:
Originally Posted by dhanushs View Post
Guys, even I faced the exact same problem on a Figo Exi, after about ~400kms drive from Goa to Kerala. ie, the blower was working at a reduced speed/temperature

Finally, we diagnosed the problem to be somehow associated with the temperature/direction control. When you switch off the car and start after, say about 20mins, there is no such problem. And it starts only when you touch the temperature controls.
Quote:
Originally Posted by anilisanil View Post
Same thing happened to me too! The blower just doesn't work after 400Kms. So I turn it off for sometime and it is back to normal again!! I wonder what is wrong? I too got the white misty thing out of the vents!!
But now the a/c is back to its normal working and there is no point in going to a.s.s as they dismiss the problem.
I am re-posting this from my ownership thread...

""I was coming to Chennai and suddenly the A/C became ineffective and came down. I switched off and started after one hour. It worked well till Chennai. The same issue happened while driving in Chennai also. When AC is switched on it may work or will start working after driving 15 minutes OR AC will start work immediately and stop working after driving some kms.

Checked the following before going to the SC:
1. Whether fan runs when AC is switched on.
2. Grill temperature if you have any temperature gauge.
3. Any visible dents/cuts in the condenser due to hitting of stones because of bad quality roads.

I checked the compressor and all the tubes and could not find anything abnormal.

Gave the car for AC service at MPL perungudi. The SM and SA observed the AC problems.
The grill temperature(close the AC vent inside the cabin) was 25'C against the default value of around 5'C at fan speed 1 position and max position of thermostat when tested by the Technician.

I thought it may be due to some loose connections or switch malfunction (as I do change the thermostat setting a lot). The grill temperature showed 15 degree. It was 5.5 at the time of 2nd Service. The value should be between 4.5 to 7.

Got a call from SA that there was a very minute leak (the available gas was around 100gms) in the pipe at the side top of the condenser due to the close position of the condenser screwed in the body or the frame. The pipe got a small hole due to jerk or rubbing of metal parts. They ordered for a new condenser and fitted it. Gas was filled and the car was ready at 7 pm.""

-- Ask the SC to check the quantity of the gas inside the AC system.
-- Always check the performance of AC at 1 speed only.
-- Mist is seen near the vents when the outside temp is very low.
RGK is offline   Reply With Quote
Old 1st November 2011, 19:28   #5576
BHPian
 
Join Date: Dec 2009
Location: Bangalore
Posts: 399
Thanked: 130 Times
Default re: Review: 1st-gen Ford Figo (2010)

Quote:
Originally Posted by fiery enzyme View Post
I took it to the service center for the third time about this issue and finallyt they told me that this a know thermistor problems which the company has asked the A.S.S to replace in the case of repeated complaints. Way to go Ford!
Quote:
Originally Posted by RGK View Post

-- Ask the SC to check the quantity of the gas inside the AC system.
-- Always check the performance of AC at 1 speed only.
-- Mist is seen near the vents when the outside temp is very low.
Thanks for all the inputs. I shall get these points checked. I personally feel the issue could be with a gas leak (not sure if this can cause a sudden drop in performance and then disappear) or with the blower motor regulator/thermistor as mentioned above. Planning to give it for the 20K service this friday but the real test would be my next long trip during the 3rd week of this month.
sansvk is offline   Reply With Quote
Old 1st November 2011, 20:45   #5577
BHPian
 
akshay380's Avatar
 
Join Date: Sep 2011
Location: Goa/Bangalore
Posts: 626
Thanked: 360 Times
Default re: Review: 1st-gen Ford Figo (2010)

Guys, Small help. Has anyone compiled a Figo specific PDI checklist if any? Like some problem areas unique to Figo?

Thanks,
Akshay
akshay380 is online now   Reply With Quote
Old 1st November 2011, 21:16   #5578
BHPian
 
Join Date: Aug 2011
Location: Pune
Posts: 71
Thanked: 17 Times
Default re: Review: 1st-gen Ford Figo (2010)

Figo refresh details emerge:

- Tilt steering on ZXI and Titanium variants
- USB port for the 2 DIN stereo on ZXI and Titanium variants
- Alloy wheels on top end Titanium variants

Source: ICB
morphique is online now   Reply With Quote
Old 1st November 2011, 23:22   #5579
BHPian
 
figo_mba's Avatar
 
Join Date: May 2011
Location: Jersey City, NJ
Posts: 473
Thanked: 208 Times
Default

Quote:
Originally Posted by morphique
Figo refresh details emerge:

- Tilt steering on ZXI and Titanium variants
- USB port for the 2 DIN stereo on ZXI and Titanium variants
- Alloy wheels on top end Titanium variants

Source: ICB
Just wish the tilt steering could be fitted on old figo without complexities and at a marginal cost.
This additions are going to reduce the price of second hand figos in the market.
figo_mba is offline   Reply With Quote
Old 2nd November 2011, 00:04   #5580
BHPian
 
Join Date: Nov 2009
Location: Bangalore
Posts: 832
Thanked: 201 Times
Default re: Review: 1st-gen Ford Figo (2010)

@Mustang a 1cm cut should not be a prob. It is equivalent to a stud breaking off. How did you notice it in the first place?
Also is the expected tilt steering expected to be retrofitted in older models?
wildsdi5530 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
1st-gen Hyundai i20 (2008 - 2014) : Review GTO Test-Drives & Initial Ownership Reports 869 6th December 2016 10:20
6 month old Ford Figo DCT: Battery dead 7 times! An ordeal with Bhagat Ford & Ford India Night Raven Technical Stuff 27 20th September 2016 16:25
The next-gen 2015 Ford Figo. EDIT: Now launched RavenAvi The Indian Car Scene 719 9th November 2015 03:04
Supposed spyshots of next gen Ford Figo surface JayPrashanth The Indian Car Scene 73 13th February 2015 14:43
My 1st diesel: Diamond white Ford Figo ZXI. Interior Pics on Pg 3 sameerg001 Test-Drives & Initial Ownership Reports 78 9th June 2014 02:37


All times are GMT +5.5. The time now is 23:03.

Copyright ©2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks