Go Back   Team-BHP > BHP India > Team-BHP Reviews > Test-Drives & Initial Ownership Reports


Reply
 
Thread Tools Search this Thread
Old 19th November 2010, 09:26   #46
BHPian
 
Ravi Yadav's Avatar
 
Join Date: Mar 2007
Location: UP-15
Posts: 136
Thanked: 10 Times
Default

Congrats vsk2009! The red colour looks great on the Punto and it is one of the best hatch in its class today. The mileage figures you achived are impressive .

Drive Safe .
Ravi Yadav is offline   Reply With Quote
Old 19th November 2010, 09:54   #47
BHPian
 
vsk2009's Avatar
 
Join Date: Sep 2009
Location: Goa
Posts: 156
Thanked: 22 Times
Default

Thanks Klub Class & Ravi Yadav. What is your opinion of going for a rear spoiler for Punto. I have not seen Punto with rear spoiler on road. Still confused whether to go or not. It will visually add more length to it. Getz in our family looks better with spoiler.
vsk2009 is offline   Reply With Quote
Old 19th November 2010, 14:16   #48
BHPian
 
samsan02's Avatar
 
Join Date: Oct 2009
Location: Bangalore
Posts: 404
Thanked: 17 Times
Default

Quote:
Originally Posted by vsk2009 View Post
Appearance of warning light can be seen between 52-55 sec. Does the rpm needle behave in the same way in your car while idling(Punto 1.4 owners).
Warning light will also come when parked with your hand brake engaged, thats how it is. That light may be due to the hand brake, so disengage it and see if the light disappears.

RPM needle usually goes up a bit and seetles at 850 mark when just after a ignition.
samsan02 is offline   Reply With Quote
Old 19th November 2010, 21:11   #49
BHPian
 
vsk2009's Avatar
 
Join Date: Sep 2009
Location: Goa
Posts: 156
Thanked: 22 Times
Default

Quote:
Originally Posted by samsan02 View Post
Warning light will also come when parked with your hand brake engaged, thats how it is. That light may be due to the hand brake, so disengage it and see if the light disappears.
RPM needle usually goes up a bit and seetles at 850 mark when just after a ignition.
Thanks. But battery, Fuel injuction failure and engine oil warning lamps should turn off once the ignition is on. If it appear then there is some problem. In my case the Fuel injection failure light is blinking.
vsk2009 is offline   Reply With Quote
Old 23rd November 2010, 20:16   #50
BHPian
 
vsk2009's Avatar
 
Join Date: Sep 2009
Location: Goa
Posts: 156
Thanked: 22 Times
Default bubbles coolant chamber

I am attaching here the picture of bubbles in coolant tank. Is it normal?
Also when I checked the engine oil level it shows 3/4 th of max(picture attached). I think usually the level will be max for a new vehicle.
Attached Thumbnails
My  Grande Punto 1.4 Emotion in Red has arrived :Initial ownership & review-dsc01543.jpg  

My  Grande Punto 1.4 Emotion in Red has arrived :Initial ownership & review-dsc01546.jpg  

vsk2009 is offline   Reply With Quote
Old 23rd November 2010, 22:41   #51
Distinguished - BHPian
 
nkrishnap's Avatar
 
Join Date: May 2006
Location: Bangalore
Posts: 3,490
Thanked: 4,103 Times
Default

@VSK, Both the pictures that you have posted is normal.

The first one, is the condensation of the moisture, dont worry about it.

The second one, perfectly normal as the complete oil will not be located in the oil sump. it would be in the head assembly and other parts of the engine. Just ensure the oil level does not drop below the low mark and not exceed the max mark.

By the check the oil level in the morning when the car is left idle for atleast 4 hours
nkrishnap is offline   Reply With Quote
Old 24th November 2010, 10:23   #52
BHPian
 
gopikb's Avatar
 
Join Date: Nov 2009
Location: Bangalore
Posts: 422
Thanked: 117 Times
Default

vsk, for the past one week, I have been observing my car at idle after cold start in the morning to see if the injection failure lamp glows. In my 2 minutes of observation, I did not see this any time in the car.

I came across a similar issue reported by gaurav in Polo which they corrected by resetting the Engine malfunction code. Read thread below for details
http://www.team-bhp.com/forum/test-d...en-polo-7.html

This could be something similar as well. But the rpm shooting up is a concern when the light appears. Did you send the video that you had taken to FIAT for their comments?
gopikb is offline   Reply With Quote
Old 24th November 2010, 20:52   #53
BHPian
 
vsk2009's Avatar
 
Join Date: Sep 2009
Location: Goa
Posts: 156
Thanked: 22 Times
Default

Thanks Nkrishnap.
Quote:
Originally Posted by gopikb View Post
vsk, for the past one week, I have been observing my car at idle after cold start in the morning to see if the injection failure lamp glows. In my 2 minutes of observation, I did not see this any time in the car.

I came across a similar issue reported by gaurav in Polo which they corrected by resetting the Engine malfunction code. Read thread below for details
http://www.team-bhp.com/forum/test-d...en-polo-7.html

This could be something similar as well. But the rpm shooting up is a concern when the light appears. Did you send the video that you had taken to FIAT for their comments?
I had send the video to fiat service Pune. Got the email id by calling them.
They told service people will call me. Today I observed another problem . I got a warning message "Excess radiator temp" "turn off Engine " and I saw temperature needle shooting up and coming back to normal position. EOBD yellow light appeared. Took the vehicle to showroom to check the oil level.
They told 3/4th level is normal. Today morning when I took the vehicle warning light issue was not there. I think it is something to do with ECU. I will update once I resolve the issue(hope). Thanks for the link.
vsk2009 is offline   Reply With Quote
Old 15th December 2010, 17:39   #54
BHPian
 
Join Date: May 2010
Location: Bangalore
Posts: 47
Thanked: 0 Times
Default Re: My Grande Punto 1.4 Emotion in Red has arrived :Initial ownership & review

Quote:
Originally Posted by vsk2009 View Post
Thanks Nkrishnap.
Today I observed another problem . I got a warning message "Excess radiator temp" "turn off Engine " and I saw temperature needle shooting up and coming back to normal position. EOBD yellow light appeared. .
I had the problem of 'Excess fluid temp, please stop and start the engine'. I went to the Service center today and they mentioned that it was because of 'loose connection' in the temp sensor and have fixed it. Let me observe if this issue reappears.
ancientmariner is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My FIAT Grande Punto 1.2 Dynamic - Initial ownership review BigBrad Test-Drives & Initial Ownership Reports 54 30th January 2016 00:46
Grande Punto, Red Emotion Pack Multijet Diesel 9000 km - 4 months - Saga continues SamtheLeo Test-Drives & Initial Ownership Reports 54 12th February 2010 21:30


All times are GMT +5.5. The time now is 23:00.

Copyright ©2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks