Team-BHP

Team-BHP (https://www.team-bhp.com/forum/)
-   Technical Stuff (https://www.team-bhp.com/forum/technical-stuff/)
-   -   vapor lock (https://www.team-bhp.com/forum/technical-stuff/28444-vapor-lock.html)

yogi1771 5th September 2007 15:37

vapor lock
 
Recently while on a trip to Shirdi my car(fiesta1.6) faced the problem of vapor lock i think so(all symptoms of vapor lock were present) had faced this problem earlier also,what can be done to prevent this from happening again
p.s had faced a scary situation due to this while overtaking there was a sudden loss of power

gd1418 5th September 2007 18:54

I used to hear about this vapour lock way back when I used to drive an Amby. The mechanical fuel pump's diaphragm used to stop working when hot. So a bit of water splash or tying a wet cloth used to solve this problem.

Present day cars have electronic fuel pumps and they should not suffer vapour lock, more so if they are injector assisted.

Quote:

Originally Posted by yogi1771 (Post 554222)
Recently while on a trip to Shirdi my car(fiesta1.6) faced the problem of vapor lock i think so(all symptoms of vapor lock were present) had faced this problem earlier also,what can be done to prevent this from happening again
p.s had faced a scary situation due to this while overtaking there was a sudden loss of power


yogi1771 5th September 2007 19:03

thats what i was thinking maybe the fuel pump is working up when it gets too hot

vnabhi 6th September 2007 13:11

I think I saw a similar post in Orkut in the Fiesta community.
Yogi--how did you get the vapour lock fixed on the earlier occassion?
Are you sure it is a vapour lock. I remember I was in a similar loss of power and jerking situation a decade ago on my M800, but the problem was diagonised as a faulty condenser, that was changed for Rs 80 only!
But it was real scary to drive 100 kms till I reached the workshop.

yogi1771 6th September 2007 16:24

hi vnabhi i parked the car for a while started it again and it ran just fine and i am not sure weather its vapor lock or the fuel pump is acting up,because read somewhere modern cars don't suffer from vapor lock problem(also as said by gd1418)

malgudi 6th September 2007 17:23

Yogi,
In my Indica, had a problem where in while driving suddenly the car would loose all power. It was like if somebody turned off the ignition. The car would restart normaly if left idle for 5-10 mins and work fine. Ofcourse this would happen at the point when the right or left indicator was activated. After a check up found that a connector which carries the power from the battery(it is right next to the battery in indica) was shorting. Had to replace this connector. Hope this helps..

gd1418 6th September 2007 18:22

Malgudi's post suddenly reminds me and this relates to petrol engines. If the ignition coil is faulty then also these symptoms would occur. A faulty coil would get hot and then malfunction.

yogi1771 6th September 2007 18:31

well this problem which i am facing occurs very rarely never while driving in the city or for that matter till date only twice while on the highway


All times are GMT +5.5. The time now is 02:04.