Team-BHP

Team-BHP (https://www.team-bhp.com/forum/)
-   Technical Stuff (https://www.team-bhp.com/forum/technical-stuff/)
-   -   Swift VDI problem (https://www.team-bhp.com/forum/technical-stuff/56314-swift-vdi-problem.html)

Sprucegoose 6th April 2009 12:58

Swift VDI problem
 
Hi guys,
a friend of mine has a swift turbo deisel.

yesterday, the while driving, a hissing sound started coming from the car [only when the accelerator was pressed.]

Soon, the turbo [which spools at around 2K RPM] kick stopped happening, the car started spewing out fumes and the milage dropped rather drastically.

What could the problem be?

rippergeo 6th April 2009 21:42

Sounds like a case of boost leak. Should be easily fixed.

SS-Traveller 6th April 2009 21:59

Quote:

Originally Posted by rippergeo (Post 1249054)
Sounds like a case of boost leak. Should be easily fixed.

+1 to that - turbo pipe came off. Nothing serious or expensive.

anupmathur 6th April 2009 21:59

Quote:

Originally Posted by Sprucegoose (Post 1248013)
Soon, the turbo [which spools at around 2K RPM] kick stopped happening, the car started spewing out fumes and the milage dropped rather drastically.

Seems like the hose at turbo air outlet has a leak or has come off.

...but how do you make out mileage drop so quickly?! :Shockked:

Sprucegoose 7th April 2009 01:27

we were on our way back from goa...

one tank full was more than enough to get there, but fell way short on the way back.

ghostrider 6th July 2009 12:37

Quote:

Originally Posted by Sprucegoose (Post 1249291)
we were on our way back from goa...

one tank full was more than enough to get there, but fell way short on the way back.

Did you get this resolved?
Normally... if you post a problem... please post the resolution as well because it helps other members who search for the same issues to know what happened, and what was done to fix it.


All times are GMT +5.5. The time now is 23:58.