Team-BHP > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 5th August 2005, 10:13   #1
BHPian
 
Join Date: Dec 2004
Location: Mumbai
Posts: 71
Thanked: 3 Times
Default Baleno- Drop in Pick-up

For past couple of days, I have been noticing a drop in the My Baleno's pick-up... Its done about 7500 kms in 4 mths and has had the first 2 services....

Initially, i thot it could have been coz of the tyre pressure being seemingly low.. got it topped up yesterday and found the same issue ...

could it be coz of the air filter getting dirty/clogged... thanx to all the dirt and grime on account of the Mumbai rains over the past few weeks...

wot could probably be the reason ?
vivaid is offline  
Old 5th August 2005, 10:43   #2
Team-BHP Support
 
Samurai's Avatar
 
Join Date: Jan 2005
Location: Banglore-Udupi
Posts: 24,306
Thanked: 25,608 Times
Default

Just go to the Maruti service station and get it checked out. We all can only speculate.
Samurai is offline  
Old 5th August 2005, 10:53   #3
BHPian
 
Join Date: Dec 2004
Location: Mumbai
Posts: 71
Thanked: 3 Times
Default

Would personally have preferred that too.. but thanx to the deluge of cars that got stuck @ the flood at all the work stations... just too difficult to get an apptmt there
vivaid is offline  
Old 5th August 2005, 10:59   #4
BHPian
 
Revvhead's Avatar
 
Join Date: Apr 2005
Location: Bombay
Posts: 450
Thanked: 15 Times
Default

pop open the air filter.
Have a look
anyway, in my excessive maintainece book, 7500 is time to change the air filter anyway
Its always advisable.
Considering how dusty the air in BBay is, i am vey particular abt the air filter. I generally try and dry clean (with air or just shake of the dust) every 2.5K and used to change it every 5k.
keeps the FE and performance up and expense is low.
Revvhead is offline  
Old 5th August 2005, 21:34   #5
Senior - BHPian
 
speedsatya's Avatar
 
Join Date: May 2004
Location: bangalore/manga
Posts: 3,159
Thanked: 726 Times
Default

see if plugs are properly tightened.chek the plug wires,
clean the air filter with compressed air,it its clogged.

check the timing as well


check your fuel lines .cud be a clogged fuel filter also ,though at 7500 kms it is not possible.


or it cud also be dragging brakes.


try changing the fuel pump.injectors could also be clogged.


cu dalso be improper tappet setting.

does your engine overheat
speedsatya is offline  
Reply

Most Viewed
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Copyright 2000 - 2020, Team-BHP.com
Proudly powered by E2E Networks