Team-BHP > In-Car Entertainment


Reply
 
Search this Thread
Old 1st August 2022, 14:25   #1
BHPian
 
Join Date: Feb 2022
Location: Bangalore
Posts: 47
Thanked: 67 Times
Infractions: 0/1 (5)
Default Android Auto keeps disconnecting from audio head-unit

Folks,

I recently got a Tata Punch. One of the issues I am facing is that Android Auto keeps disconnection from the head unit. Initially, I thought this might be because the cable came loose while going over a bump, but later I was able to see that this was not the case. It just seemed to be disconnecting at random. It sometimes disconnects right when I press the horn.

Any pointers? (Clearing the cache etc doesn't seem to be fixing it.)

Last edited by Aditya : 1st August 2022 at 17:40. Reason: Edited for better readability
blitz_nomad is offline   (1) Thanks Received Infraction
Old 1st August 2022, 19:31   #2
BHPian
 
Join Date: Oct 2020
Location: Noida
Posts: 88
Thanked: 341 Times
Default re: Android Auto keeps disconnecting from audio head-unit

Try these:
1. Different cable
2. Different phone
3. Factory reset Infotainment system
4. Backup and factory reset phone(do so at your own peril)
5. Visit Service center
MotoBlip is offline  
Old 1st August 2022, 19:33   #3
BHPian
 
GrandTourer's Avatar
 
Join Date: Aug 2018
Location: Bangalore
Posts: 384
Thanked: 1,243 Times
Default re: Android Auto keeps disconnecting from audio head-unit

Quote:
Originally Posted by blitz_nomad View Post
Folks,

I recently got a Tata Punch. One of the issues I am facing is that Android Auto keeps disconnection from the head unit. Initially, I thought this might be because the cable came loose while going over a bump, but later I was able to see that this was not the case. It just seemed to be disconnecting at random. It sometimes disconnects right when I press the horn.

Any pointers? (Clearing the cache etc doesn't seem to be fixing it.)
Been there! Get a small cable. I got a 1 ft cable which solved the problem. Longer cable results in connection dropping randomly. This has been discussed extensively in multiple AA forums. Here's a support doc from Samsung: https://www.samsung.com/za/support/m...-android-auto/

Ever since I moved to a smaller cable about 3 years ago, I have never experienced connection dropping.

Last edited by GrandTourer : 1st August 2022 at 19:34. Reason: Punctuation.
GrandTourer is offline   (5) Thanks
Old 1st August 2022, 20:24   #4
BHPian
 
prashantuchil's Avatar
 
Join Date: Sep 2020
Location: Bangalore
Posts: 25
Thanked: 32 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

Quote:
Originally Posted by blitz_nomad View Post
Folks,

I recently got a Tata Punch. One of the issues I am facing is that Android Auto keeps disconnection from the head unit. Initially, I thought this might be because the cable came loose while going over a bump, but later I was able to see that this was not the case. It just seemed to be disconnecting at random. It sometimes disconnects right when I press the horn.

Any pointers? (Clearing the cache etc doesn't seem to be fixing it.)
Another TIP - Keep the cable secured (it should not shake a lot). I have routed and taped the cable under the dashboard to the spot near the phone holder. This seems to have sorted the disconnection issue.
prashantuchil is offline   (2) Thanks
Old 1st August 2022, 21:53   #5
BHPian
 
Join Date: Jul 2020
Location: Hyderbad
Posts: 665
Thanked: 2,285 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

I will tell you from my experience. If you have a long cable, wire it closely and tag it tightly. It should not be more than half a feet long. Use only the direct plug in rather than an accessory that has multiple charging points. Also, ensure the settings are set such that the contacts get downloaded each time you make/receive a call. If all the above are not working, it's definitely a tech issue and TATA has to fix it through a patch. Raise it with your dealer and when there is a new software update, ensure to get it done. Keep us posted please.
Raghu M is offline   (1) Thanks
Old 2nd August 2022, 02:18   #6
BHPian
 
21Archer84's Avatar
 
Join Date: Jun 2012
Location: Columbus/HYD
Posts: 349
Thanked: 312 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

I have been facing the same issue since I got my Tiguan here a month ago.
Watched a video on YouTube that suggested to wrap the cable with an Electrical tape to make sure the cable sits perfectly in the slot. However, it doesn't help a bit.
Looking forward for a solution.
Will try with Iphone and CarPlay just to confirm it is an issue with Hardware or Software.
21Archer84 is offline   (1) Thanks
Old 2nd August 2022, 07:39   #7
BHPian
 
Gypsian's Avatar
 
Join Date: Jun 2022
Location: Bangalore
Posts: 166
Thanked: 506 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

Is it not covered under warranty? It’s your recent purchase, don’t break your head with DIY fix. Get it fixed from the concerned authorized dealer or get it replaced.
Gypsian is offline  
Old 2nd August 2022, 07:59   #8
Senior - BHPian
 
Join Date: Aug 2010
Location: Madras
Posts: 2,458
Thanked: 3,056 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

Use the OEM cable. I have/had a dedicated OEM cable for car. It is always connected. The only time I unplug is when the car is at the workshop every 10K for the service.

This is not just restricted to Android Auto, happens in Carplay as well.

If you still see disconnections, this might be on the cable connecting the USB inlet to headunit, which has to be resolved at service center. Although replicating this intermittent problem might be a task.

Last edited by narayans80 : 2nd August 2022 at 08:01.
narayans80 is offline   (1) Thanks
Old 2nd August 2022, 11:29   #9
Senior - BHPian
 
harry10's Avatar
 
Join Date: Jul 2008
Location: Faridabad/Delhi
Posts: 2,616
Thanked: 2,536 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

Quote:
Originally Posted by narayans80 View Post
Use the OEM cable. I have/had a dedicated OEM cable for car. It is always connected. The only time I unplug is when the car is at the workshop every 10K for the service.
This.
And if someone doesn't have an OEM cable. Buy the 2 in 1 Mi cable from Amazon. It has both USB C and other one for older phones. I use it in my car and never had any issues.
harry10 is offline   (2) Thanks
Old 4th August 2022, 14:13   #10
BHPian
 
Join Date: Dec 2019
Location: Roaming in KA
Posts: 44
Thanked: 136 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

Quote:
Originally Posted by MotoBlip View Post
Try these:
1. Different cable
2. Different phone
3. Factory reset Infotainment system
4. Backup and factory reset phone(do so at your own peril)
5. Visit Service center
I too wasted an enormous amount of time and money on troubleshooting with Android Auto. I went to the extent of getting the USB C port changed on my Pixel trying to resolve this issue, because somebody told that lint could get trapped inside & lead to intermittent connections.

Best thing is to borrow an iPhone from a friend and try with Carplay for some time. This should at least help to narrow down if it is phone/OS issue or a head-unit issue. That is how I got to know it is an issue with the OS & not the head-unit.

Before changing to the iPhone recently, I used to face a lot of similar issues on Android Auto, including with the Google Pixel phones.

After my switch to Carplay; in the exact same cars & head-units; it has been rock solid. So changed my OS instead of cars...

Last edited by car_addict : 4th August 2022 at 14:24. Reason: Grammar
car_addict is offline   (1) Thanks
Old 4th August 2022, 14:44   #11
BHPian
 
deep_bang's Avatar
 
Join Date: Mar 2007
Location: Bangalore / Boise
Posts: 769
Thanked: 824 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

Quote:
Originally Posted by car_addict View Post
Before changing to the iPhone recently, I used to face a lot of similar issues on Android Auto, including with the Google Pixel phones.

After my switch to Carplay; in the exact same cars & head-units; it has been rock solid. So changed my OS instead of cars...
Before making this a android auto vs carplay let's understand that there are many of us using android auto flawlessly. Just for the record I also use wireless auto quite successfully without any disconnections with my Samsung Galaxy s20Fe. So let's try to logically understand and conclude one of the below:
1. The cable is not as good as it should be (most likely cause, also cheapest to confirm)
2. The android auto on the phone side has a problem ( can be confirmed by another phone, preferably an android one just to prove that it's not an android problem per se but potentially the particular phone in this case.)
3. The car's music system has an issue. (If this is the case forums like ours should be highlighting this so that the car makes fix it and make it work).

I think we need the OP to try out the cable first and then see how to go to the next step.
deep_bang is offline   (1) Thanks
Old 4th August 2022, 15:20   #12
BHPian
 
2himanshu's Avatar
 
Join Date: Nov 2015
Location: A Blue Dot
Posts: 136
Thanked: 738 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

Please also check the cable slot at some mobile repair shop, if phone is old, it accumulates dust, clearing it helped me!

I have an iPhone & CarPlay hangs sometimes in my JTP, but in my friend's Alturas G4, it worked flawlessly all day long.
2himanshu is offline  
Old 4th August 2022, 15:51   #13
BHPian
 
Join Date: Sep 2009
Location: Bombay
Posts: 764
Thanked: 989 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

Two phone companies which I have noticed have issues with Android Auto are OnePlus (especially) and Xiaomi.

No such issues with Samsung & Nokia (yes, they make vanilla Android phones).
invidious is offline  
Old 4th August 2022, 16:59   #14
Newbie
 
Join Date: Mar 2022
Location: Chennai
Posts: 7
Thanked: 4 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

I bought a C-type cable from Amazon for connecting my Redmi phone to nexon and initially i had this problem. Subsequently i changed the cable to the original supplied along with the phone and it got resolved. Nowadays, i dont remove the cable from car.
Krishna sankar is offline  
Old 4th August 2022, 18:19   #15
BHPian
 
21Archer84's Avatar
 
Join Date: Jun 2012
Location: Columbus/HYD
Posts: 349
Thanked: 312 Times
Default Re: Android Auto keeps disconnecting from audio head-unit

Guys, the cable appears to be the culprit here.
Based on my search over the web, the USB 3.0 and above cables seem to work for Android Auto. Have a look at the reviews for USB 3.1 type A to C cables and you'll realize the same. Apparently, Android Auto needs a robust hardware for seamless data transfer.
Anker Powerline ii/ ii+ seems to be the most recommended if using a non-OEM cable. Unfortunately, the Powerline ii+ is out of stock here. I will get a Powerline ii or USB 3.1 cable from other reputed brands and confirm if it works.
I currently have a Belkin and Mivi cables and the Belkin appears to have less disconnections over the Mivi one.
Also, I tried wrapping the end of the USB A side with an electrical cable to see if it helps avoiding any loose contact, but didn't work.
21Archer84 is offline   (1) Thanks
Reply

Most Viewed
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Copyright 2000 - 2022, Team-BHP.com
Proudly powered by E2E Networks