Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 14th May 2017, 01:21   #1
BHPian
 
harsha.muvva's Avatar
 
Join Date: Jan 2014
Location: hyderabad
Posts: 228
Thanked: 342 Times
Default Ford Endeavour: Stalling & random acceleration issue

Update on Stalling/shuddering issue

My Endeavour was completely fine may first week and nearing the 30k kms and I planned to send the vehicle to the service centre in few days. However I was surprised to face series of issues which were totally unexpected and quite dangerous. For better understanding I will list down the sequence of events

Day 1 (April 28th) - My chauffeur who drives the endeavour regularly called up me tensed early in the morning and complained that the vehicle is not slowing even after lifting foot off throttle and made a heavy noise of 'over-revving". It happened around 4-5 times when the speed was above 80 kmph. Only on pressing brakes, the car started slowing down. Also the car stalled once when taking a "U-Turn"

Day 2 - I got to see and drive the vehicle but I could not experience the 'Un-intended acceleration' (term borrowed from google). However the refused to start after I parked it at home, it threw up 'Wrench error' and displayed 'Check Manual'. I tried multiple times to start it, but it simply refused to start. I couldn't hear any cranking sound either. However after around 10-15 minutes, it started again and the wrench symbol disappeared. I managed to click the photo when it showed the error. Attaching the picture of same. You can notice the symbol in right bottom of display.

Ford Endeavour: Stalling & random acceleration issue-img_0016.jpg

By this time, I have already mailed 'Ford India' customer care along with the details of my preferred service centre i.e "Fortune Ford, Tolichowki". I got a call from the "AGM" of service centre who was very courteous and assured me of 100% support from his side. I have sent the vehicle and instructed them to do the '30k kms" service along with 'FM radio" software update. I got a call from him for every 2-3 hours updating me about the status of vehicle. Their OBD scan showed error code P0341 - CMP Sensor error, for which they have cleaned the sensor and connectors. However they do not have any answer when I asked why the sensor became loose . Along with this they have also updated the 'Power Control module' (PCM) with the latest one. The AGM also sent me pictures of OBD Scan before & after sensor adjustment. Attaching the photos.

Error - P0341 - CMP sensor
Ford Endeavour: Stalling & random acceleration issue-img_0017.jpg

After
Ford Endeavour: Stalling & random acceleration issue-img_0018.jpg

I was told the issue is resolved and they couldn't find anything in their test-drive too. So I have picked the vehicle and have done around 100 kms in between and couldn't find any issues. However after 2 days, when my chauffeur was returning from our home town along with my father, the endeavour stalled again but this time when he slowed down near toll-gate. When cranked again, it started but again it stalled within few metres. This has happened around 3 to 4 times near toll gate. Needless to say my father was both embarrassed and irritated by this. Fortunately It didn't stall again and once I was made aware of this, I sent the vehicle immediately to the same service centre and put a strong worded email to 'Ford India' Customer care.

The staff in the service centre were very surprised at this and even they do not know what the problem can be. However I was kept updated regularly. According to the SA and AGM, Ford India was directly monitoring and guiding them to trouble shoot the issue. They were instructed to check the entire wiring harness/couplers/ground points..etc. This time their diagnostic tool didn't show any errors. On searching various forums, I noticed that this is/was a frequent problem in few ford models like explorer/escape..etc and replacing the wiring harness solved the issue. Ford has even issued a TSB (Technical service bulletin) for the same. I have shared the links and screenshots regarding this issue from forums to both 'Ford India' and the service centre email/whatsapp. However didn't receive any satisfactory reply on this. They took multiple road-tests after checking the wiring harness and could not find any issues. I received the vehicle from them with an assurance that problem will not repeat again.

Attaching the references regarding the service bulletin i found on ford forums

Name:  IMG_0019.JPG
Views: 19296
Size:  121.9 KB

Ford Endeavour: Stalling & random acceleration issue-img_0020.jpg

I have got multiple feedback calls from 'Ford India' after receiving the vehicle from dealership and strongly asked them to tell me the root cause for this issue (for which the dealership has no answer) and also asked them to write that it has been throughly troubleshooted & will not recur again. I was promised over phone that they will send me a mail acknowledging the same, However I haven't gotten any mail yet (its been 4 days since i have take the vehicle).

Have driven the vehicle for around 400 kms after taking it from service centre, It haven't stalled 'Yet'. I shall be doing another 500 kms in coming week and will update on this thread in case if i find any. I sincerely hope its just one-off instance as its quite scary to imagine car accelerating on its own and stalling randomly at odd times . This is the very reason I was pestering Ford to provide a longer extended warranties, no response on that too. I think if the problem repeats again, they will replace the wiring harness.

PS : I would also like to know if anyone else is facing the issue. One of the Bhp-ian also mentioned that he also experienced this, but only once till now and unfortunately for him the service centre refused saying there is nothing wrong as they couldn't replicate the issue. Also would like to know opinion of experts on the forum regarding this issue.
harsha.muvva is offline   (20) Thanks Reply With Quote
Old 14th May 2017, 19:47   #2
BHPian
 
Join Date: Mar 2008
Location: TVM, BLR, HYD
Posts: 585
Thanked: 761 Times
Default re: Ford Endeavour: Stalling & random acceleration issue

I was googling around and the error seems to be related to the camshaft position sensor. The symptoms you reported are the ones mentioned in the links below. Loose connection is a possibility (but that needs explanation) and i think the location is near the injectors. The other possible cause is PCM not able to get signals from the CMP sensor, let's see if the software update fixes the issue.

And are you sure there were no water washing/servicing done inside the engine bay ? My Safari's ECU (2.2 Dicor) was bust after a washing routine at Concorde motors, Bangalore. Symptoms were exactly similar to what you reported and cleaning helps for a short duration but the problem will come back. Replaced the ECU under warranty and never had any issues till 1,00,000kms.

Please share the feedback after your trip.

For peace of mind, I'd suggest you test the camshaft position sensor. An example can be found here

Links for reference:

https://www.obd-codes.com/p0341

http://www.troublecodes.net/pcodes/p0341/

https://www.yourmechanic.com/article...by-jay-safford

Last edited by sunishsamuel : 14th May 2017 at 19:54.
sunishsamuel is offline   (9) Thanks Reply With Quote
Old 15th May 2017, 10:37   #3
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,748
Thanked: 7,469 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

Quoting from the link provided from sunishsamuel.

Quote:
Originally Posted by sunishsamuel View Post
Quote:
Common Causes of P0341

Depending on year, make, and model, DTC P0341 or P0346 may have number of causes. Here are some of the most common.

Faulty Sensor – If the sensor coil is open or shorted, then it will generate no signal.
Poor Installation – A good CMP signal is highly dependent on placement. Generally, the sensor needs between 0.020” and 0.050” clearance to the reluctor ring or camshaft tooth. If the sensor is cocked to one side or not firmly seated, the clearance will be wrong and the signal will be too weak for the ECU to detect. If the reluctor ring is rubbing on the sensor, the signal will be distorted.
Ford Trucks / Mustang GT – An alternator phase problem, such as a blown diode or open coil, may cause so much electrical interference that the CMP signal gets distorted, causing a P0341 / P0346 DTC to set, among others, in spite of there being no actual problem with the CMP sensor or wiring.
Cars in Storage – If your car has been in storage for any length of time, rodents may find it a great nesting place. Unfortunately, while looking for nesting materials and cleaning house, these little critters might find your wiring offensive or even tasty, resulting in open circuit problems.
Older Cars – Over time, plastic and rubber tends to become brittle and less flexible, which can lead to connector breakage and wire insulation damage. In turn, this may cause corrosion, open circuits, or short circuits.

Generally, the camshaft position sensor is pretty resilient and long-lived, which doesn’t necessary rule it out as a problem, but most of the time, the problem lies in the wiring and connectors for the sensor, or something else entirely. Before you just jump right on a new sensor, make sure you can rule out the rest of the system, first.

Codes Related to P0341

DTC P0341 or P0346 may be accompanied by other DTCs, such as P0300 Random Misfire, P0725 Engine Speed Sensor Circuit, or P0335 Crankshaft Position Sensor Circuit Malfunction.
From the screen shot of error codes, there seems to be other errors that has been recorded. Diagnosis has to take into consideration those codes also, without which pin pointing might not be accurate.

But yes common google search indicates to a faulty cam sensor / connection, but it can be related to wiring harness and connection also, for that matter a low battery also can throw this error! If at all this happens again, please ask dealer to share all the error codes and related messages with Ford factory so that they can give a comprehensive solution.
Jaggu is online now   (2) Thanks Reply With Quote
Old 15th May 2017, 11:11   #4
Newbie
 
Join Date: Mar 2017
Location: Trivandrum
Posts: 5
Thanked: 5 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

It is really frustrating when we are faced with similar problems which cannot be replicated at the service center. I owned a Maruti Zen Petrol several years back and it refuses to start once in a while. We can hear engine cranking but car doesn't start. Popular Service were never able to identify the problem though it was mostly assumed that it is a loose contact in the Engine Immobiliser sensor. Traded in the Car with Popluar itself and bought a Dzire to avoid the hefty price tag of a Wiring harness replacement.
Parameswaran is offline   Reply With Quote
Old 15th May 2017, 13:50   #5
BHPian
 
harsha.muvva's Avatar
 
Join Date: Jan 2014
Location: hyderabad
Posts: 228
Thanked: 342 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

Quote:
Originally Posted by sunishsamuel View Post
I was googling around and the error seems to be related to the camshaft position sensor. The symptoms you reported are the ones mentioned in the links below. Loose connection is a possibility (but that needs explanation) and i think the location is near the injectors. The other possible cause is PCM not able to get signals from the CMP sensor, let's see if the software update fixes the issue.
Yeah, when the SA first shared the error code with me I googled up and found them related to CMP. Even the AGM/SA said its related to CMP and on inspection they found it to be loose. However on asking why it was loose, even they do not have a any answer. So I was told, they checked the resistance across the sensor and found it to be completely normal (this test was mentioned on one of forums too). So they just cleaned the connections and replugged it. On connecting to OBD and scanning, the couldn't find any error after that. So we thought the problem was solved

But only after the problem re-appeared again and on further reading through other international forums, I thought it 'might' be related to wiring harness. However the service centre and 'Ford India' did not feel so, so they just checked/tightened the complete wiring harness again. You can go through the following links regarding the wiring harness issue.

1. http://www.fordescape.org/forum/engi...e-driving.html

2. http://www.lemonlaw.com/wordpress/fo...cles-recalled/



Quote:
. Symptoms were exactly similar to what you reported and cleaning helps for a short duration but the problem will come back.
This is what I am more worried about. I am almost sure that problem will repeat again as neither Ford India nor the dealer could not tell me what exactly the problem is

Quote:
Originally Posted by Jaggu View Post
But yes common google search indicates to a faulty cam sensor / connection, but it can be related to wiring harness and connection also, for that matter a low battery also can throw this error! If at all this happens again, please ask dealer to share all the error codes and related messages with Ford factory so that they can give a comprehensive solution.
Ture, both faulty CMP sensor and faulty wiring harness can lead to shuddering, stalling and refusing to start randomly. However I couldn't find much information on the random acceleration part which we experienced on our endeavour. If at all it happens again, I will make sure to be along with vehicle for whole duration.
harsha.muvva is offline   (2) Thanks Reply With Quote
Old 15th May 2017, 20:55   #6
Distinguished - BHPian
 
SS-Traveller's Avatar
 
Join Date: Jan 2009
Location: New Delhi
Posts: 6,617
Thanked: 10,779 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

Quote:
Originally Posted by harsha.muvva View Post
[b]
I have ... strongly asked them to tell me the root cause for this issue (for which the dealership has no answer) and also asked them to write that it has been throughly troubleshooted & will not recur again. I was promised over phone that they will send me a mail acknowledging the same, However I haven't gotten any mail yet (its been 4 days since i have take the vehicle).
...I was pestering Ford to provide a longer extended warranties, no response on that too. I think if the problem repeats again, they will replace the wiring harness.

Also would like to know opinion of experts on the forum regarding this issue.
Serious issue...

Not an expert on Ford Endeavour electronics, but here's my two bits:

The problem appears to be serious to the customer/driver because of the unwanted erratic behaviour (acceleration, shuddering, stalling, refusing to start), but in general, I'd say electronic gremlins in any car are going to become more and more common over the coming years, especially in India - mainly because of a bunch a semi-trained semi-literate half-monkeys populating the service centres - unless the automobile manufacturers start hiring people in the service centres who understand electronics and computers in the context of the modern IC engine.

But then, show a roadside mechanic a Tesla and tell him it isn't starting, and he'll probably open the bonnet and peer inside for half an hour, then bill you a few hundred bucks for it.
SS-Traveller is offline   (18) Thanks Reply With Quote
Old 16th May 2017, 21:44   #7
BHPian
 
Join Date: Sep 2015
Location: KOLKATA INDIA
Posts: 95
Thanked: 161 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

Quote:
Originally Posted by SS-Traveller View Post
Serious issue...

Not an expert on Ford Endeavour electronics, but here's my two bits:

The problem appears to be serious to the customer/driver because of the unwanted erratic behaviour (acceleration, shuddering, stalling, refusing to start), but in general, I'd say electronic gremlins in any car are going to become more and more common over the coming years, especially in India - mainly because of a bunch a semi-trained semi-literate half-monkeys populating the service centres - unless the automobile manufacturers start hiring people in the service centres who understand electronics and computers in the context of the modern IC engine.

But then, show a roadside mechanic a Tesla and tell him it isn't starting, and he'll probably open the bonnet and peer inside for half an hour, then bill you a few hundred bucks for it.
As long as automobile dealerships pay peanuts to their staff, be it sales or service, the experience shall be never up to the mark. We all know, if you pay peanuts you get monkeys!!

Myself, having 21 years in the automobile industry (sales and product training - within India and abroad) have been forced to look to change my industry just because of the peanut salary that is on offer.

I do not blame the dealerships - they are squeezed on margins, so they tend to go in for the cheapest man power with quality man power not being considered.
ALTIMAed is offline   (6) Thanks Reply With Quote
Old 16th May 2017, 23:40   #8
BHPian
 
parth.jain's Avatar
 
Join Date: Aug 2015
Location: New Delhi
Posts: 73
Thanked: 100 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

A friend's figo diesel had a similar stalling issue. The car would stall anywhere, anytime randomly. It even stalled once while taking a right turn at an intersection.

A simple 'software update' solved the issue for him. I believe the ECU was updated.

I know that the Endeavour is a totally different car as compared to Figo but both of them are from the same manufacturer and the problem was similar.
parth.jain is offline   (1) Thanks Reply With Quote
Old 17th May 2017, 09:41   #9
BHPian
 
SHANKY11's Avatar
 
Join Date: Oct 2012
Location: New Delhi
Posts: 83
Thanked: 296 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

This is quite serious. Sorry to hear about your bad experience after spending so much to own a so called premium SUV. Please do update soon if the problem resurfaces. I have just booked my Endy recently and now I am seriously worried. If it is a constant problem, then I'm sure I will not go for it and will probably look elsewhere.
SHANKY11 is offline   (1) Thanks Reply With Quote
Old 17th May 2017, 12:29   #10
BHPian
 
harsha.muvva's Avatar
 
Join Date: Jan 2014
Location: hyderabad
Posts: 228
Thanked: 342 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

UPDATE

I have been in touch with "Ford India" team for last two days regarding the issue. According to them its because of a 'loose connection' in CMP sensor to which the error code relates, the plugged and cleaned it properly - cleared error codes and the problem was resolved. However, they couldn't tell anything when I asked what might be the reason for a loose sensor connection. Also they couldn't explain me why the stalling has repeated even after taking delivery of vehicle after 'fixing CMP sensor, solved the issue'. They are also unable to exactly tell me the root cause of stalling for second time. The only thing they keep on repeating is "We have thoroughly checked wiring harness and found no problem". The only people who are calling/mailing me are from Customer relations, sales..etc, unfortunately they have to rely on information supplied to them by technical team. I think even the technical team do not know why the vehicle stalled for second time (or unwilling to share the information).

On a positive note, I got assurance in writing that my problem has been thoroughly investigated, resolved and will not repeat again. Also they have provided me third year extended extended warranty as a good will gesture. Also the overall promptness and response of both 'Ford India' and my dealer 'Fortune Ford, tolichwoki' has been excellent, they are unable to give me a satisfactory technical explanation. Like 'SS-Traveller' has mentioned, looks like we will have to live with it.

PS : Endeavour has done approximately 500 kms post the second visit to workshop. It hasn't stalled 'YET'.
harsha.muvva is offline   (9) Thanks Reply With Quote
Old 17th May 2017, 12:45   #11
BHPian
 
Join Date: Sep 2006
Location: Bangalore
Posts: 157
Thanked: 27 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

Harsha,

Was checking team bhp site after a while. This is similar to what i had experienced. I have​ given the details in the ownership thread and for me the solution was changing sensor. But, the service center folks tried adjusting the sensor and that actually compounded the issue of not being able to start. The issue was fixed inly after they replaced cam shaft position sensor (CMP). It is also documented in Australian forum as a known issue.

Fortunately, I did not face the problem of car stalling while on the road. It simply refused to start in the morning.
tortoise is offline   (1) Thanks Reply With Quote
Old 17th May 2017, 14:32   #12
BHPian
 
roby_dk's Avatar
 
Join Date: Nov 2016
Location: New Delhi
Posts: 220
Thanked: 561 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

Quote:
Originally Posted by harsha.muvva View Post
UPDATE
Also they have provided me third year extended extended warranty as a good will gesture.
Hello Harsha,
I assume we are already getting 3 years warranty on Endeavour. I think they gave you 4th year extended warranty. Please correct me if I am wrong.
roby_dk is online now   (1) Thanks Reply With Quote
Old 17th May 2017, 18:42   #13
BHPian
 
sam_sant2005's Avatar
 
Join Date: Jan 2008
Location: Bangalore
Posts: 457
Thanked: 151 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

Quick question since it is not evident from the posts, is yours the new Endeavour or the older one?
sam_sant2005 is offline   Reply With Quote
Old 17th May 2017, 19:03   #14
BHPian
 
harsha.muvva's Avatar
 
Join Date: Jan 2014
Location: hyderabad
Posts: 228
Thanked: 342 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

Quote:
Originally Posted by SHANKY11 View Post
This is quite serious. Sorry to hear about your bad experience after spending so much to own a so called premium SUV. Please do update soon if the problem resurfaces. I have just booked my Endy recently and now I am seriously worried. If it is a constant problem, then I'm sure I will not go for it and will probably look elsewhere.
I shall keep this thread updated. I still suggest the enthusiastic folks to go ahead with the new ford endeavour as there is simply no other suv which matches overall experience of endeavour at this price or at double the price. However do not expect a 'toyota like' reliabilty, again this statement is just based on my experience with old gen innova (approx 4 lakh kms in two different innovas, never had a break down)

However if you just want a 4*4 SUV without caring much about features, quality, overall luxurious experience go for Fortuner. I am hoping this issue wont repeat again.

Quote:
Originally Posted by tortoise View Post
Harsha,

Was checking team bhp site after a while. This is similar to what i had experienced. I have​ given the details in the ownership thread and for me the solution was changing sensor. But, the service center folks tried adjusting the sensor and that actually compounded the issue of not being able to start. The issue was fixed inly after they replaced cam shaft position sensor (CMP). It is also documented in Australian forum as a known issue.
.
Good to know that I am not alone. How many kilometres have you done on your endeavour? Did the issue repeat again?

Quote:
Originally Posted by roby_dk View Post
Hello Harsha,
I assume we are already getting 3 years warranty on Endeavour. I think they gave you 4th year extended warranty. Please correct me if I am wrong.
Standrad warrany is 2 years/1,00,000 kms. Extended warranry is for 1 additional year i.e 3 years/1,00,000 kms

Quote:
Originally Posted by sam_sant2005 View Post
Quick question since it is not evident from the posts, is yours the new Endeavour or the older one?
Its a 'may 2016 Endeavour 3.2 AT titanium'. So exactly 1 year old and 30,000 kms on odo.
harsha.muvva is offline   (2) Thanks Reply With Quote
Old 17th May 2017, 19:17   #15
BHPian
 
SHANKY11's Avatar
 
Join Date: Oct 2012
Location: New Delhi
Posts: 83
Thanked: 296 Times
Default Re: Ford Endeavour: Stalling & random acceleration issue

Quote:
Originally Posted by harsha.muvva View Post
I shall keep this thread updated. I still suggest the enthusiastic folks to go ahead with the new ford endeavour as there is simply no other suv which matches overall experience of endeavour at this price or at double the price. However do not expect a 'toyota like' reliabilty, again this statement is just based on my experience with old gen innova (approx 4 lakh kms in two different innovas, never had a break down)

However if you just want a 4*4 SUV without caring much about features, quality, overall luxurious experience go for Fortuner. I am hoping this issue wont repeat again.
It is good news that the issue has been resolved. I sincerely hope you dont face any issues related to this in future. Also, the prompt response and the goodwill gesture from Ford corporate is confidence inspiring for sure.

I agree that no other SUV in the segment can match upto the Endeavour. For an enthusiast, the Endeavour is a no-brainer. And if the company cares for its customers, then nothing like it. Seems like I will go ahead with my booking after all. Thanks
SHANKY11 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Triumph Street Triple - Severe stalling issue quickdraw Superbikes & Imports 116 25th October 2016 01:24
Chevrolet Lumina: Random acceleration & cruise control problem jocreative Technical Stuff 5 22nd July 2013 22:47
Mercedes E220 W124 Stalling and heating issue aquavelva Technical Stuff 11 9th October 2011 00:13
Fabia stalling issue: Dealer unable to diagnose. EDIT: Skoda agrees to replace car mayank123 Indian Car Dealerships 24 16th September 2009 13:41
Issue with VDI acceleration. Ajaybiz Technical Stuff 21 7th December 2008 18:20


All times are GMT +5.5. The time now is 15:57.

Copyright ©2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks