Team-BHP > Team-BHP Reviews > Official New Car Reviews


Reply
 
Thread Tools Search this Thread
Old 30th March 2018, 10:35   #8416
BHPian
 
Join Date: Jun 2007
Location: Pune
Posts: 280
Thanked: 44 Times
Default

Fuse socket terminal might be loose. It can be snugly fitted by slightly bending it.
omishra is offline   (1) Thanks
Old 30th March 2018, 11:45   #8417
BHPian
 
Join Date: Sep 2014
Location: Jalandhar
Posts: 249
Thanked: 354 Times
Default

Quote:
Originally Posted by govigov View Post
Do you want me to check here locally? Let me check in any case and see if they have it in stock.

Got the 26/14 from hella curvo finally. Will use them and update you guys.
roamer012 is offline  
Old 3rd April 2018, 09:57   #8418
BHPian
 
sinharishi's Avatar
 
Join Date: Apr 2013
Location: DL10C/MH47
Posts: 686
Thanked: 2,610 Times
Default Re: Maruti S-Cross : Official Review

Did back to back weekend trips to Corbett and Lucknow.

Odometer crossed 70,000 kms yesterday.


Maruti S-Cross : Official Review-accd9497ad1a4d68a966c11a86b0af9a.jpeg
sinharishi is online now   (4) Thanks
Old 3rd April 2018, 10:02   #8419
Distinguished - BHPian
 
Dr.Naren's Avatar
 
Join Date: Dec 2015
Location: Bangalore
Posts: 4,954
Thanked: 15,307 Times
Default Re: Maruti S-Cross : Official Review

Quote:
Originally Posted by sinharishi View Post
Odometer crossed 70,000 kms yesterday.
Congrats. This should be the fastest S-Cross on Team BHP . I mean 0-70,000 KM. Many 1.3 owners have faced coolant leakage issue due to faulty thermostat. Since you drive a lot on highways, better to get it changed.
Dr.Naren is online now   (1) Thanks
Old 3rd April 2018, 11:12   #8420
Team-BHP Support
 
Eddy's Avatar
 
Join Date: Apr 2007
Location: Delhi
Posts: 8,880
Thanked: 10,140 Times
Default Re: Maruti S-Cross : Official Review

Quote:
Originally Posted by Dr.Naren View Post
Many 1.3 owners have faced coolant leakage issue due to faulty thermostat. Since you drive a lot on highways, better to get it changed.
Thanks for the headsup, although mine is relatively young at 35k.

Has this issue been reported on the forum ?
Eddy is online now  
Old 3rd April 2018, 11:16   #8421
Distinguished - BHPian
 
Dr.Naren's Avatar
 
Join Date: Dec 2015
Location: Bangalore
Posts: 4,954
Thanked: 15,307 Times
Default Re: Maruti S-Cross : Official Review

Quote:
Originally Posted by Eddy View Post
Has this issue been reported on the forum ?
Yes, there are many cases. Few are reported here on Team BHP itself.

http://www.team-bhp.com/forum/techni...xperience.html

http://www.team-bhp.com/forum/offici...ml#post4252293

http://www.team-bhp.com/forum/test-d...ml#post4355572
Dr.Naren is online now   (4) Thanks
Old 3rd April 2018, 11:24   #8422
Team-BHP Support
 
Eddy's Avatar
 
Join Date: Apr 2007
Location: Delhi
Posts: 8,880
Thanked: 10,140 Times
Default Re: Maruti S-Cross : Official Review

Wow, thanks for this. I recently did a highway trip and checked the coolant and oil levels before the drive. All seemed okay. Will need to keep a check.
Eddy is online now  
Old 3rd April 2018, 11:26   #8423
Distinguished - BHPian
 
Dr.Naren's Avatar
 
Join Date: Dec 2015
Location: Bangalore
Posts: 4,954
Thanked: 15,307 Times
Default Re: Maruti S-Cross : Official Review

Quote:
Originally Posted by Eddy View Post
Wow, thanks. I recently did a highway trip and checked the coolant and oil levels before the drive. All seemed okay. Will need to keep a check.
Maruti has not even done silent recall for this issue. Usually they would send circular to dealers with VIN numbers of the affected batch. This issue is random, but couple of 1.3 owners are affected. I know at least 5 more 1.3 owners who faced this.
Dr.Naren is online now  
Old 3rd April 2018, 19:32   #8424
BHPian
 
Join Date: Feb 2015
Location: Pune
Posts: 75
Thanked: 99 Times
Default Re: Maruti S-Cross : Official Review

Quote:
Originally Posted by rickygupta2 View Post
Finally, after taking delivery of my 1.3 Zeta on March 19th I had an opportunity to take it the first time for a weekend trip. The total distance covered is 900 km. A few observations about the car.
I feel you have to be gentle with car for running -in period of 1000 km to let engine settle. Mileage will increase post subsequent servicing.

Last edited by ampere : 3rd April 2018 at 22:45. Reason: quoted post trimmed
findviru is offline   (1) Thanks
Old 3rd April 2018, 21:57   #8425
BHPian
 
Sree73's Avatar
 
Join Date: Feb 2016
Location: Bangalore
Posts: 798
Thanked: 973 Times
Default

Quote:
Originally Posted by findviru View Post
Mileage will increase post subsequent servicing.
Please do not quote complete long messages while replying. It adversely affect the reading experience. Quote the relevant portion of the messages.
Sree73 is offline   (1) Thanks
Old 4th April 2018, 11:15   #8426
BHPian
 
Join Date: Dec 2007
Location: Hyderabad
Posts: 168
Thanked: 92 Times
Default Dash Board Rattles

Has anyone faced rattling noise from the dashboard?

This has popped up on my 6 months old scross. This started after the first service and was coming from the right hand side of the dashboard near the Start/Stop Button, service center guys fixed it twice, but it restarts after a week or so. While they fixed it temporarily rattling noise has started from the left hand side of the dashboard and is louder too

Earlier service center guys gave the weird reason" Because the goggles placed in the slot provided for them, these move around and the noise is stemming from here ". I have taken them out and placed them in Storage area under the center armrest.

I am yet to send it to the Service center for third time for this issue, My worry is because of the frequent dismantling of the dashboard, will it cause more problems? any inputs on how to get this fixed?

Thanks

Last edited by Aditya : 4th April 2018 at 15:56. Reason: Fixing typos, please review your post once before submitting to avoid the mistakes. Thanks.
zaveed is offline   Received Infraction
Old 4th April 2018, 14:22   #8427
BHPian
 
Dieselritzer's Avatar
 
Join Date: Jul 2012
Location: Mumbai
Posts: 572
Thanked: 1,381 Times
Default

Never make Maruti open the dashboard. Your car will never be the same again. Live with the rattle rather than to invite more while trying to fix one.
Dieselritzer is online now   (2) Thanks
Old 4th April 2018, 14:45   #8428
BHPian
 
ankan.m.blr's Avatar
 
Join Date: Dec 2011
Location: Bangalore
Posts: 751
Thanked: 802 Times
Default Re: Maruti S-Cross : Official Review

Copying my post from the ICE thread, for an issue with my Scross HU. I am facing a strange bug with my April-2017 Scross ( updated to the latest software version from Maruti A.S.S. in January; AA is running fine). From last 2 weeks, the option to select 'Aux' as audio input is not present in the media menu. Other options are there as before (Bluetooth, SD Card, USB etc ) only the AUX option is absent now. I was able to see that option until 2 weeks back. Any suggestion guys?
ankan.m.blr is offline  
Old 4th April 2018, 15:38   #8429
BHPian
 
Join Date: Dec 2007
Location: Hyderabad
Posts: 168
Thanked: 92 Times
Default Re: Maruti S-Cross : Official Review

Quote:
Originally Posted by Dieselritzer View Post
Never make Maruti open the dashboard. Your car will never be the same again. Live with the rattle rather than to invite more while trying to fix one.
I think i have gone past this twice till now

Earlier the noise was low, sent it to service center hoping for a fix, now the noise loud :(

Another question. Has any faced the issue of number's getting displayed twice? If i check on the phone for a particular contact there is only 1 mobile number, but when i want to dial this contact and pull up the mobile number from the touch screen, the same number is displayed twice and this is not specific to one contact, this is happening for all contacts.

Thanks

Last edited by zaveed : 4th April 2018 at 15:45.
zaveed is offline  
Old 4th April 2018, 16:37   #8430
Senior - BHPian
 
arvind71181's Avatar
 
Join Date: May 2010
Location: TN-14
Posts: 1,059
Thanked: 1,487 Times
Default Re: Maruti S-Cross : Official Review

Quote:
Originally Posted by ankan.m.blr View Post
Copying my post from the ICE thread, for an issue with my Scross HU. I am facing a strange bug with my April-2017 Scross ( updated to the latest software version from Maruti A.S.S. in January; AA is running fine). From last 2 weeks, the option to select 'Aux' as audio input is not present in the media menu. Other options are there as before (Bluetooth, SD Card, USB etc ) only the AUX option is absent now. I was able to see that option until 2 weeks back. Any suggestion guys?
I think in the settings, there is an option to enable aux/dvd player mode (or) both. Please check if that works for you
arvind71181 is online now   (1) Thanks
Reply

Most Viewed
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Copyright 2000 - 2022, Team-BHP.com
Proudly powered by E2E Networks